Skip to content

← Actionable
High, CVSS 7.5

Meridian: Multiple defense-in-depth gaps (collection/depth caps, telemetry, retry, fan-out)

GHSA-f5v8-v6q3-q4h6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (meridian.mapping 2.1.1; meridian.mediator 2.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary Meridian v2.1.0 (Meridian.Mapping and Meridian.Mediator) shipped with nine defense-in-depth gaps reachable through its public APIs. Two are HIGH severity — the advertised DefaultMaxCollectionItems and DefaultMaxDepth safety caps are silently bypassed on the IMapper.Map(source, destination) overload and anywhere .UseDestinationValue() is configured on a collection-typed property. Four are MEDIUM (constructor invariant bypass, OpenTelemetry stack-trace info disclosure, retry amplification, notification fan-out amplification). Three are LOW (exception message disclosure, dictionary duplicate-key echo, static mediator cache growth under closed-generic types). All nine are patched in v2.1.1. Upgrade is a drop-in NuGet bump; see the v2.1.1 CHANGELOG for the four behavioural changes (constructor selection, OTel default, publisher fan-out cap, retry caps). Severity Matrix |

| Severity | CWE | Finding | Fix | |---|---|---|---|---| | 1 | HIGH | CWE-770 |…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f5v8-v6q3-q4h6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-f5v8-v6q3-q4h6

Advisory: Meridian: Multiple defense-in-depth gaps (collection/depth caps, telemetry, retry, fan-out)
IDs: GHSA-f5v8-v6q3-q4h6
Record: https://patchnext.com/advisories/ghsa-f5v8-v6q3-q4h6 (revision 1, source checked 26 Oct 2026, 17:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: meridian.mapping 2.1.1; meridian.mediator 2.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet meridian.mapping: affected >= 2.0.0, < 2.1.1; fixed in 2.1.1
- NuGet meridian.mediator: affected >= 2.0.0, < 2.1.1; fixed in 2.1.1

## Suggested inspection (read-only)
- NuGet meridian.mapping: check the installed version with your package manager.
- NuGet meridian.mediator: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on meridian.mapping, meridian.mediator.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f5v8-v6q3-q4h6 (GitHub-reviewed advisory GHSA-f5v8-v6q3-q4h6 lists affected ranges: NuGet meridian.mapping >=2.0.0 =2.0.0 <2.1.1)

Commands are suggestions: review each one before running it.

Loading voting…