Skip to content

← Actionable
Medium, CVSS 5.3amended

Svelte: SSR XSS via Insecure Promise Serialization in hydratable

GHSA-f3cj-j4f6-wq85

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (svelte 5.55.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm svelte

    Affected
    >= 5.46.0, <= 5.55.6
    Fixed in
    5.55.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Contents of hydratable promises were not properly stringified, potentially leading to an XSS exploit. You are vulnerable if all of the following is true: - you are using hydratable (an experimental feature at the time of this report) - you are passing attacker-controlled input such that a synchronous value is hydrated, then a promise value, e.g. hydratable('someKey', () = [synchronousValue, promiseValue])

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-f3cj-j4f6-wq85

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-f3cj-j4f6-wq85

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-f3cj-j4f6-wq85

Advisory: Svelte: SSR XSS via Insecure Promise Serialization in hydratable
IDs: GHSA-f3cj-j4f6-wq85
Record: https://patchnext.com/advisories/ghsa-f3cj-j4f6-wq85 (revision 3, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: svelte 5.55.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm svelte: affected >= 5.46.0, <= 5.55.6; fixed in 5.55.7

## Suggested inspection (read-only)
- `npm ls svelte --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on svelte.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f3cj-j4f6-wq85 (OSV record GHSA-f3cj-j4f6-wq85 lists affected ranges: npm svelte >=5.46.0 <5.55.7 (fixed))
- Verified: https://github.com/advisories/GHSA-f3cj-j4f6-wq85 (GitHub-reviewed advisory GHSA-f3cj-j4f6-wq85 lists affected ranges: npm svelte >=5.46.0 <=5.55.6)

Commands are suggestions: review each one before running it.

Loading voting…