Skip to content

← Actionable
High, CVSS 7.5

silverstripe/framework has possible denial of service attack vector when flushing

GHSA-cwgq-83w5-8jfq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/framework 4.2.2, 4.1.3, 4.0.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist silverstripe/framework

    Affected
    >= 4.0.0-rc1, < 4.0.5>= 4.1.0-rc1, < 4.1.3>= 4.2.0-rc1, < 4.2.2
    Fixed in
    4.1.3, 4.2.2, 4.0.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

A possible denial of service attack vector has been identified in the dev/build system controller. dev/build now has its own URL token, similar to flushtoken, to ensure users are authenticated when running dev/build outside of dev environments.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cwgq-83w5-8jfq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-cwgq-83w5-8jfq

Advisory: silverstripe/framework has possible denial of service attack vector when flushing
IDs: GHSA-cwgq-83w5-8jfq
Record: https://patchnext.com/advisories/ghsa-cwgq-83w5-8jfq (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: silverstripe/framework 4.2.2, 4.1.3, 4.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist silverstripe/framework: affected >= 4.0.0-rc1, < 4.0.5; >= 4.1.0-rc1, < 4.1.3; >= 4.2.0-rc1, < 4.2.2; fixed in 4.1.3, 4.2.2, 4.0.5

## Suggested inspection (read-only)
- Packagist silverstripe/framework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on silverstripe/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cwgq-83w5-8jfq (GitHub-reviewed advisory GHSA-cwgq-83w5-8jfq lists affected ranges: Packagist silverstripe/framework >=4.0.0-rc1 =4.1.0-rc1 =4.2.0-rc1 <4.2.2)

Commands are suggestions: review each one before running it.

Loading voting…