Skip to content

← Actionable
Medium, CVSS 6.5amended

a12nserver vulnerable to potential SQL Injections via Knex dependency

GHSA-crhg-xgrg-vvcc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@curveball/a12n-server 0.23.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact Users of a12nserver that use MySQL might be vulnerable to SQL injection bugs. If you use a12nserver and MySQL, update as soon as possible. This SQL injection bug might let an attacker obtain OAuth2 Access Tokens for users unrelated to those that permitted OAuth2 clients. Patches The knex dependency has been updated to 2.4.0 in a12nserver 0.23.0 Workarounds No further workarounds References https://github.com/knex/knex/issues/1227 https://nvd.nist.gov/vuln/detail/CVE-2016-20018 https://www.ghostccamm.com/blog/knexsqli/

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-crhg-xgrg-vvcc

  2. Revision 1 · created ·

    Published from osv record GHSA-crhg-xgrg-vvcc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-crhg-xgrg-vvcc

Advisory: a12nserver vulnerable to potential SQL Injections via Knex dependency
IDs: GHSA-crhg-xgrg-vvcc
Record: https://patchnext.com/advisories/ghsa-crhg-xgrg-vvcc (revision 2, source checked 26 Oct 2026, 12:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @curveball/a12n-server 0.23.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @curveball/a12n-server: affected >= 0.20.0, < 0.23.0; fixed in 0.23.0

## Suggested inspection (read-only)
- `npm ls @curveball/a12n-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @curveball/a12n-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-crhg-xgrg-vvcc (OSV record GHSA-crhg-xgrg-vvcc lists affected ranges: npm @curveball/a12n-server >=0.20.0 <0.23.0 (fixed))
- Verified: https://github.com/advisories/GHSA-crhg-xgrg-vvcc (GitHub-reviewed advisory GHSA-crhg-xgrg-vvcc lists affected ranges: npm @curveball/a12n-server >=0.20.0 <0.23.0)

Commands are suggestions: review each one before running it.

Loading voting…