Saltcorn's Reflected XSS and Command Injection vulnerabilities can be chained for 1-click-RCE
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@saltcorn/server 1.5.0-beta.19), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @saltcorn/server
- Affected
- >= 1.1.1, < 1.5.0-beta.19
- Fixed in
- 1.5.0-beta.19
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cr3w-cw5w-h3fj lists affected ranges: npm @saltcorn/server >=1.1.1 <1.5.0-beta.19
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cr3w-cw5w-h3fj lists affected ranges: npm @saltcorn/server >=1.1.1 <1.5.0-beta.19 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary 1. There is a reflected XSS vulnerability in the GET /admin/edit-codepage/:name route through the name parameter. This can be used to hijack the session of an admin if they click a specially crafted link. 2. Additionally, there is a Command Injection vulnerability in GET /admin/backup. The admin can inject a shell command in the backup password which is inserted in the command used to create the backup zip. Both vulnerabilities can be chained to craft a malicious link which will execute an arbitrary shell command on the server if it is clicked by a saltcorn admin with an active session. I believe iframes could also be used to exploit this silently when the admin visits an attacker-controlled web page (though I have not tested that). Details 1. The XSS vulnerability is here: https://github.com/saltcorn/saltcorn/blob/020893c0001678fd5ebd2c088ba68b395de1aabc/packages/server/routes/admin.js#L4886-L4887 Specifically, the name parameter is inserted into the pages breadcrumbs…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-cr3w-cw5w-h3fj
- Revision 2 · amended ·
Amended from osv record GHSA-cr3w-cw5w-h3fj
- Revision 1 · created ·
Published from ghsa record GHSA-cr3w-cw5w-h3fj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-cr3w-cw5w-h3fj Advisory: Saltcorn's Reflected XSS and Command Injection vulnerabilities can be chained for 1-click-RCE IDs: GHSA-cr3w-cw5w-h3fj Record: https://patchnext.com/advisories/ghsa-cr3w-cw5w-h3fj (revision 3, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @saltcorn/server 1.5.0-beta.19. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @saltcorn/server: affected >= 1.1.1, < 1.5.0-beta.19; fixed in 1.5.0-beta.19 ## Suggested inspection (read-only) - `npm ls @saltcorn/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @saltcorn/server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cr3w-cw5w-h3fj (GitHub-reviewed advisory GHSA-cr3w-cw5w-h3fj lists affected ranges: npm @saltcorn/server >=1.1.1 <1.5.0-beta.19) - Verified: https://osv.dev/vulnerability/GHSA-cr3w-cw5w-h3fj (OSV record GHSA-cr3w-cw5w-h3fj lists affected ranges: npm @saltcorn/server >=1.1.1 <1.5.0-beta.19 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…