Vite Plugin React has a Denial of Service Vulnerability in React Server Components
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@vitejs/plugin-rsc 0.5.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 0.5.6
- Fixed in
- 0.5.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cpqf-f22c-r95x lists affected ranges: npm @vitejs/plugin-rsc >=0 <0.5.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cpqf-f22c-r95x lists affected ranges: npm @vitejs/plugin-rsc >=0 <=0.5.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact @vitejs/plugin-rsc vendors react-server-dom-webpack, which contained a vulnerability in versions prior to 19.2.3. See details in React repository's advisory https://github.com/facebook/react/security/advisories/GHSA-7gmr-mq3h-m5h9 Patches Upgrade immediately to @vitejs/plugin-rsc@0.5.7 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cpqf-f22c-r95x
- Revision 1 · created ·
Published from osv record GHSA-cpqf-f22c-r95x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-cpqf-f22c-r95x Advisory: Vite Plugin React has a Denial of Service Vulnerability in React Server Components IDs: GHSA-cpqf-f22c-r95x Record: https://patchnext.com/advisories/ghsa-cpqf-f22c-r95x (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @vitejs/plugin-rsc 0.5.7. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @vitejs/plugin-rsc: affected <= 0.5.6; fixed in 0.5.7 ## Suggested inspection (read-only) - `npm ls @vitejs/plugin-rsc --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @vitejs/plugin-rsc. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cpqf-f22c-r95x (OSV record GHSA-cpqf-f22c-r95x lists affected ranges: npm @vitejs/plugin-rsc >=0 <0.5.7 (fixed)) - Verified: https://github.com/advisories/GHSA-cpqf-f22c-r95x (GitHub-reviewed advisory GHSA-cpqf-f22c-r95x lists affected ranges: npm @vitejs/plugin-rsc >=0 <=0.5.6) Commands are suggestions: review each one before running it.
Loading voting…