Poweradmin: OIDC sub collation bypass in Poweradmin leading to account takeover
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (poweradmin/poweradmin 4.3.4, 4.2.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist poweradmin/poweradmin
- Affected
- >= 4.1.0, < 4.2.5>= 4.3.0, < 4.3.4
- Fixed in
- 4.3.4, 4.2.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cmwh-g2h8-c222 lists affected ranges: Packagist poweradmin/poweradmin >=4.1.0 =4.3.0 <4.3.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Preface Poweradmin maps OIDC identities into local users through oidcuserlinks.oidcsubject plus providerid. In the MySQL schema, the OIDC link table explicitly uses utf8mb4unicodeci, which is case-insensitive and accent-insensitive. OIDC sub is a stable external subject identifier and should be matched byte-for-byte within the issuer/provider scope. The confirmed local PoC used two different OIDC users: - Victim subject: victim-login - Attacker subject: victím-login (í, U+00ED) MySQL reported those two subjects as equal under utf8mb4unicodeci. After the victim linked their OIDC account, the attacker authenticated to the same provider with the attacker's own password and Poweradmin resolved the session to the victim's local account. Server Info - Application: Poweradmin - Version: targets/poweradmin git e1f9c9a - Database: MySQL 8.4.10, charactersetserver=utf8mb4, collationserver=utf8mb4unicodeci - Access Permissions: Any user who can create or control an account in the connected OIDC…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cmwh-g2h8-c222
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-cmwh-g2h8-c222 Advisory: Poweradmin: OIDC `sub` collation bypass in Poweradmin leading to account takeover IDs: GHSA-cmwh-g2h8-c222 Record: https://patchnext.com/advisories/ghsa-cmwh-g2h8-c222 (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: poweradmin/poweradmin 4.3.4, 4.2.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist poweradmin/poweradmin: affected >= 4.1.0, < 4.2.5; >= 4.3.0, < 4.3.4; fixed in 4.3.4, 4.2.5 ## Suggested inspection (read-only) - Packagist poweradmin/poweradmin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on poweradmin/poweradmin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cmwh-g2h8-c222 (GitHub-reviewed advisory GHSA-cmwh-g2h8-c222 lists affected ranges: Packagist poweradmin/poweradmin >=4.1.0 =4.3.0 <4.3.4) Commands are suggestions: review each one before running it.
Loading voting…