Praxis affected by HTTP/2 Bomb
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (praxis-proxy 0.5.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io praxis-proxy
- Affected
- < 0.5.2
- Fixed in
- 0.5.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cjcg-cxmh-9wcr lists affected ranges: crates.io praxis-proxy >=0 <0.5.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cjcg-cxmh-9wcr lists affected ranges: crates.io praxis-proxy >=0 <0.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary Multiple denial-of-service vulnerabilities have been discovered in HTTP/2 server implementations. All have been rated with a severity impact of Important. The vulnerabilities target HPACK, the header compression scheme in HTTP/2, where a small request can trigger large memory allocations on the server. Details Credit to the original researcher, I'm mostly just run their tool against the code base. Security Bulletins: https://access.redhat.com/security/vulnerabilities/RHSB-2026-007 Exploit details: https://blog.calif.io/p/codex-discovered-a-hidden-http2-bomb This bug was fixed in upstream pingora v0.8.1, but our fork (v0.8.2) is missing this important PR to set the default h2 options. (edited) PoC Generate certificates Create praxis config as follow Start the container Check container memory In another terminal run the attack Observer the container memory Memory usage spiked to around 700MB, and even after the attack ended, the memory was not freed up. Patch the code to set…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cjcg-cxmh-9wcr
- Revision 1 · created ·
Published from osv record GHSA-cjcg-cxmh-9wcr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-cjcg-cxmh-9wcr Advisory: Praxis affected by HTTP/2 Bomb IDs: GHSA-cjcg-cxmh-9wcr Record: https://patchnext.com/advisories/ghsa-cjcg-cxmh-9wcr (revision 2, source checked 26 Oct 2026, 15:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: praxis-proxy 0.5.2. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io praxis-proxy: affected < 0.5.2; fixed in 0.5.2 ## Suggested inspection (read-only) - crates.io praxis-proxy: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on praxis-proxy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cjcg-cxmh-9wcr (OSV record GHSA-cjcg-cxmh-9wcr lists affected ranges: crates.io praxis-proxy >=0 <0.5.2 (fixed)) - Verified: https://github.com/advisories/GHSA-cjcg-cxmh-9wcr (GitHub-reviewed advisory GHSA-cjcg-cxmh-9wcr lists affected ranges: crates.io praxis-proxy >=0 <0.5.2) Commands are suggestions: review each one before running it.
Loading voting…