Skip to content

← Actionable
Low, CVSS 2.1amended

OpenClaw Google Chat spoofing access with allowlist authorized mutable email principal despite sender-ID mismatch

GHSA-chm2-m3w2-wcxm

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.2.14
    Fixed in
    2026.2.14
  • npm clawdbot

    Affected
    <= 2026.1.24-3
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary Google Chat allowlisting supports matching by sender email in addition to immutable sender resource name (users/<id). This weakens identity binding if a deployment assumes allowlists are strictly keyed by immutable principals. Affected Packages / Versions (As of 2026-02-14; based on latest published npm versions) - openclaw (npm): <= 2026.2.13 - clawdbot (npm): <= 2026.1.24-3 Details Affected component: - extensions/googlechat/src/monitor.ts The allowFrom checks accept: - Immutable sender id (users/<id) - Raw email (alice@example.com) for usability Historically, users/<email was also treated as an email allowlist entry. This is now deprecated because it looks like an immutable ID but is actually a mutable principal. Security Triage (2026-02-14) Severity: Low Rationale: - Requests are authenticated as coming from Google Chat (token verification), so this is not a generic unauthenticated spoofing vector. - A realistic exploit generally requires Google Workspace / IdP…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-chm2-m3w2-wcxm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-chm2-m3w2-wcxm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-chm2-m3w2-wcxm

Advisory: OpenClaw Google Chat spoofing access with allowlist authorized mutable email principal despite sender-ID mismatch
IDs: GHSA-chm2-m3w2-wcxm
Record: https://patchnext.com/advisories/ghsa-chm2-m3w2-wcxm (revision 3, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: openclaw 2026.2.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.2.14; fixed in 2026.2.14
- npm clawdbot: affected <= 2026.1.24-3

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls clawdbot --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw, clawdbot.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-chm2-m3w2-wcxm (OSV record GHSA-chm2-m3w2-wcxm lists affected ranges: npm openclaw >=0 =0 <=2026.1.24-3)
- Verified: https://github.com/advisories/GHSA-chm2-m3w2-wcxm (GitHub-reviewed advisory GHSA-chm2-m3w2-wcxm lists affected ranges: npm openclaw >=0 =0 <=2026.1.24-3)

Commands are suggestions: review each one before running it.

Loading voting…