Path Traversal in algo-httpserv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (algo-httpserv 1.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm algo-httpserv
- Affected
- < 1.1.2
- Fixed in
- 1.1.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cgjv-rghq-qhgp lists affected ranges: npm algo-httpserv >=0 <1.1.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cgjv-rghq-qhgp lists affected ranges: npm algo-httpserv >=0 <1.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Versions of algo-httpserv prior to 1.1.2 are vulnerable to Path Traversal. Due to insufficient input sanitization, attackers can access server files by using relative paths. Recommendation Upgrade to version 1.1.2 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cgjv-rghq-qhgp
- Revision 1 · created ·
Published from osv record GHSA-cgjv-rghq-qhgp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-cgjv-rghq-qhgp Advisory: Path Traversal in algo-httpserv IDs: GHSA-cgjv-rghq-qhgp Record: https://patchnext.com/advisories/ghsa-cgjv-rghq-qhgp (revision 2, source checked 26 Oct 2026, 12:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: algo-httpserv 1.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm algo-httpserv: affected < 1.1.2; fixed in 1.1.2 ## Suggested inspection (read-only) - `npm ls algo-httpserv --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on algo-httpserv. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cgjv-rghq-qhgp (OSV record GHSA-cgjv-rghq-qhgp lists affected ranges: npm algo-httpserv >=0 <1.1.2 (fixed)) - Verified: https://github.com/advisories/GHSA-cgjv-rghq-qhgp (GitHub-reviewed advisory GHSA-cgjv-rghq-qhgp lists affected ranges: npm algo-httpserv >=0 <1.1.2) Commands are suggestions: review each one before running it.
Loading voting…