Skip to content

← Actionable
High, CVSS 7.2amended

OpenRemote has Authenticated SQL Injection via Datapoint Crosstab Export

CVE-2026-62238GHSA-cgfv-jrfp-2r7v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.openremote:openremote-manager 1.26.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-62238: 0.50% estimated exploitation activity in the next 30 days; percentile 42.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
  • CVE-2026-63224: 0.34% estimated exploitation activity in the next 30 days; percentile 27.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The datapoint export API builds a PostgreSQL crosstab export query by concatenating asset display names into raw SQL. An authenticated user who can create or rename an asset and then request a crosstab datapoint export can inject SQL through the asset name. The injected query output is streamed back to the caller inside the normal ZIP/CSV export response. This creates a practical database exfiltration primitive through the application API. In a multi-tenant deployment, this can expose data outside the attacker's tenant if the application database role can read shared manager tables.

Affected Component - Datapoint export endpoint for asset datapoints. - Crosstab export formats, specifically CSV crosstab-style exports. - Query builder path that constructs a `COPY (SELECT ... FROM crosstab(...)) TO STDOUT` statement.

Security Impact Impact is high. A remote authenticated attacker with asset read/write capabilities can: - Store SQL syntax inside an asset name. - Trigger…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-cgfv-jrfp-2r7v

  2. Revision 1 · created ·

    Published from ghsa record GHSA-cgfv-jrfp-2r7v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-62238

Advisory: OpenRemote has Authenticated SQL Injection via Datapoint Crosstab Export
IDs: CVE-2026-62238, GHSA-cgfv-jrfp-2r7v
Record: https://patchnext.com/advisories/ghsa-cgfv-jrfp-2r7v (revision 2, source checked 1 Nov 2026, 06:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.openremote:openremote-manager 1.26.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.openremote:openremote-manager: affected < 1.26.0; fixed in 1.26.0

## Suggested inspection (read-only)
- Maven io.openremote:openremote-manager: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.openremote:openremote-manager.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cgfv-jrfp-2r7v (GitHub-reviewed advisory GHSA-cgfv-jrfp-2r7v lists affected ranges: Maven io.openremote:openremote-manager >=0 <1.26.0)
- Verified: https://osv.dev/vulnerability/GHSA-cgfv-jrfp-2r7v (OSV record GHSA-cgfv-jrfp-2r7v lists affected ranges: Maven io.openremote:openremote-manager >=0 <1.26.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…