Skip to content

← Actionable
Medium, CVSS 6.5amended

Nodemailer: Recipient-domain validation bypass via RFC 5322 comment mis-parsing leads to email delivery to an attacker-controlled domain

CVE-2026-92597GHSA-cc9r-2j5m-2m83

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nodemailer 9.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm nodemailer

    Affected
    >= 6.9.16, < 9.1.0
    Fixed in
    9.1.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N
EPSS
  • CVE-2026-92597: 0.38% estimated exploitation activity in the next 30 days; percentile 32.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Nodemailer's email-address parser treats an RFC 5322 comment ( ... ) inside the domain as a point to concatenate the surrounding text, rather than as folding whitespace (CFWS) that terminates the domain. Consequently a recipient address such as user@good-corp.com(x)evil.com is parsed and delivered to good-corp.comevil.com (registrable domain comevil.com, attacker‑controlled), while a conformant RFC 5322 parser terminates the domain at the comment and reads good-corp.com. An application that decides whether it is allowed to email a recipient by parsing/validating the recipient's domain — with a strict RFC 5322 parser (used without inspecting parse defects) or with a naive prefix/substring allow‑list — and then hands the raw address to Nodemailer for delivery, can be induced to send mail to a domain the attacker controls. This is an Interpretation Conflict (CWE‑436), the same class as CVE‑2025‑13033, reached through the RFC 5322 comment construct (the "Comments" technique in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-cc9r-2j5m-2m83

  2. Revision 2 · amended ·

    Amended from osv record GHSA-cc9r-2j5m-2m83

  3. Revision 1 · created ·

    Published from ghsa record GHSA-cc9r-2j5m-2m83

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-92597

Advisory: Nodemailer: Recipient-domain validation bypass via RFC 5322 comment mis-parsing leads to email delivery to an attacker-controlled domain
IDs: CVE-2026-92597, GHSA-cc9r-2j5m-2m83
Record: https://patchnext.com/advisories/ghsa-cc9r-2j5m-2m83 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nodemailer 9.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm nodemailer: affected >= 6.9.16, < 9.1.0; fixed in 9.1.0

## Suggested inspection (read-only)
- `npm ls nodemailer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nodemailer.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cc9r-2j5m-2m83 (GitHub-reviewed advisory GHSA-cc9r-2j5m-2m83 lists affected ranges: npm nodemailer >=6.9.16 <9.1.0)
- Verified: https://osv.dev/vulnerability/GHSA-cc9r-2j5m-2m83 (OSV record GHSA-cc9r-2j5m-2m83 lists affected ranges: npm nodemailer >=6.9.16 <9.1.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…