eZ Publish Information disclosure in backend content tree menu
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ezsystems/ezpublish-legacy 2017.8.1.1, 5.4.10.1, 5.3.12.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist ezsystems/ezpublish-legacy
- Affected
- >= 2011.0.0, < 2017.8.1.1>= 5.4.0, < 5.4.10.1>= 5.3.0, < 5.3.12.2
- Fixed in
- 5.4.10.1, 5.3.12.2, 2017.8.1.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cc2j-92jq-wgjg lists affected ranges: Packagist ezsystems/ezpublish-legacy >=2011.0.0 =5.4.0 =5.3.0 <5.3.12.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
This security advisory fixes an information disclosure vulnerability in the legacy admin content tree menu. If a view has been disabled in site.ini [SiteAccessRules] Rules, and an attacker accesses the backend with the URL to this module, then the tree menu may be displayed. Since the tree menu may contain hidden items, this may lead to information disclosure. We recommend that you install this Security Update as soon as possible. To install, use Composer to update to one of the "Resolving versions" mentioned above, or apply this patch manually: https://github.com/ezsystems/ezpublish-legacy/commit/a4a0470f8d80f012fe14e4f8ab11c7d14375986c
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cc2j-92jq-wgjg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-cc2j-92jq-wgjg Advisory: eZ Publish Information disclosure in backend content tree menu IDs: GHSA-cc2j-92jq-wgjg Record: https://patchnext.com/advisories/ghsa-cc2j-92jq-wgjg (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ezsystems/ezpublish-legacy 2017.8.1.1, 5.4.10.1, 5.3.12.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist ezsystems/ezpublish-legacy: affected >= 2011.0.0, < 2017.8.1.1; >= 5.4.0, < 5.4.10.1; >= 5.3.0, < 5.3.12.2; fixed in 5.4.10.1, 5.3.12.2, 2017.8.1.1 ## Suggested inspection (read-only) - Packagist ezsystems/ezpublish-legacy: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ezsystems/ezpublish-legacy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cc2j-92jq-wgjg (GitHub-reviewed advisory GHSA-cc2j-92jq-wgjg lists affected ranges: Packagist ezsystems/ezpublish-legacy >=2011.0.0 =5.4.0 =5.3.0 <5.3.12.2) Commands are suggestions: review each one before running it.
Loading voting…