mezzio-swoole Applications Using Diactoros Vulnerable to HTTP Host Header Attack
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mezzio/mezzio-swoole 4.3.0, 3.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist mezzio/mezzio-swoole
- Affected
- < 3.7.0>= 4.0.0, < 4.3.0
- Fixed in
- 4.3.0, 3.7.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c8rp-cgf4-937w lists affected ranges: Packagist mezzio/mezzio-swoole >=0 =4.0.0 <4.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact mezzio-swoole applications using Diactoros for their PSR-7 implementation, and which are either not behind a proxy, or can be accessed via untrusted proxies, can potentially have the host, protocol, and/or port of a Laminas\Diactoros\Uri instance associated with the incoming server request modified to reflect values from X-Forwarded- headers. Such changes can potentially lead to XSS attacks (if a fully-qualified URL is used in links) and/or URL poisoning. Patches 3.7.0, and 4.3.0 and later. The patches present in these versions update the SwooleServerRequestFactory to filter out X-Forwarded- headers when creating the initial request. They then by default pass that instance through a Laminas\Diactoros\ServerRequestFilter\FilterUsingXForwardedHeaders instance created from the trustReservedSubnet() constructor, ensuring that the request only honors the X-Forwarded- headers for private reserved subnets. Users can define the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c8rp-cgf4-937w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-c8rp-cgf4-937w Advisory: mezzio-swoole Applications Using Diactoros Vulnerable to HTTP Host Header Attack IDs: GHSA-c8rp-cgf4-937w Record: https://patchnext.com/advisories/ghsa-c8rp-cgf4-937w (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mezzio/mezzio-swoole 4.3.0, 3.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist mezzio/mezzio-swoole: affected < 3.7.0; >= 4.0.0, < 4.3.0; fixed in 4.3.0, 3.7.0 ## Suggested inspection (read-only) - Packagist mezzio/mezzio-swoole: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mezzio/mezzio-swoole. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c8rp-cgf4-937w (GitHub-reviewed advisory GHSA-c8rp-cgf4-937w lists affected ranges: Packagist mezzio/mezzio-swoole >=0 =4.0.0 <4.3.0) Commands are suggestions: review each one before running it.
Loading voting…