Phoenix-ws source code and data in extensions folder is publicly available
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phoenix-ws 1.0.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI phoenix-ws
- Affected
- < 1.0.6
- Fixed in
- 1.0.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c8f7-x2g7-7fxj lists affected ranges: PyPI phoenix-ws >=0 <1.0.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c8f7-x2g7-7fxj lists affected ranges: PyPI phoenix-ws >=0 <1.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact All of the source code, files, and folders in phoenixfiles/extensions/ are available to end users through a simple HTTP GET request. Patches The issue has been patched. The users of version 1.0.6 and above are not effected.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-c8f7-x2g7-7fxj
- Revision 1 · created ·
Published from osv record GHSA-c8f7-x2g7-7fxj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-c8f7-x2g7-7fxj Advisory: Phoenix-ws source code and data in extensions folder is publicly available IDs: GHSA-c8f7-x2g7-7fxj Record: https://patchnext.com/advisories/ghsa-c8f7-x2g7-7fxj (revision 2, source checked 26 Oct 2026, 13:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phoenix-ws 1.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI phoenix-ws: affected < 1.0.6; fixed in 1.0.6 ## Suggested inspection (read-only) - `python -m pip show phoenix-ws`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phoenix-ws. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-c8f7-x2g7-7fxj (OSV record GHSA-c8f7-x2g7-7fxj lists affected ranges: PyPI phoenix-ws >=0 <1.0.6 (fixed)) - Verified: https://github.com/advisories/GHSA-c8f7-x2g7-7fxj (GitHub-reviewed advisory GHSA-c8f7-x2g7-7fxj lists affected ranges: PyPI phoenix-ws >=0 <1.0.6) Commands are suggestions: review each one before running it.
Loading voting…