Skip to content

← Actionable
Medium, CVSS 4.0

Timing side channel vulnerability in UIDL request handler in Vaadin 10, 11-14, and 15-18

GHSA-c6c4-7x48-4cqp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.vaadin:vaadin-bom 18.0.6, 14.4.7, 10.0.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven com.vaadin:vaadin-bom

    Affected
    >= 10.0.0, < 10.0.17>= 11.0.0, < 14.4.7>= 15.0.0, < 18.0.6
    Fixed in
    14.4.7, 18.0.6, 10.0.17

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.0 · CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Non-constant-time comparison of CSRF tokens in UIDL request handler in com.vaadin:flow-server versions 1.0.0 through 1.0.13 (Vaadin 10.0.0 through 10.0.16), 1.1.0 prior to 2.0.0 (Vaadin 11 prior to 14), 2.0.0 through 2.4.6 (Vaadin 14.0.0 through 14.4.6), 3.0.0 prior to 5.0.0 (Vaadin 15 prior to 18), and 5.0.0 through 5.0.2 (Vaadin 18.0.0 through 18.0.5) allows attacker to guess a security token via timing attack. - https://vaadin.com/security/cve-2021-31404

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-c6c4-7x48-4cqp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-c6c4-7x48-4cqp

Advisory: Timing side channel vulnerability in UIDL request handler in Vaadin 10, 11-14, and 15-18
IDs: GHSA-c6c4-7x48-4cqp
Record: https://patchnext.com/advisories/ghsa-c6c4-7x48-4cqp (revision 1, source checked 26 Oct 2026, 15:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.vaadin:vaadin-bom 18.0.6, 14.4.7, 10.0.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.vaadin:vaadin-bom: affected >= 10.0.0, < 10.0.17; >= 11.0.0, < 14.4.7; >= 15.0.0, < 18.0.6; fixed in 14.4.7, 18.0.6, 10.0.17

## Suggested inspection (read-only)
- Maven com.vaadin:vaadin-bom: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.vaadin:vaadin-bom.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c6c4-7x48-4cqp (GitHub-reviewed advisory GHSA-c6c4-7x48-4cqp lists affected ranges: Maven com.vaadin:vaadin-bom >=10.0.0 =11.0.0 =15.0.0 <18.0.6)

Commands are suggestions: review each one before running it.

Loading voting…