TYPO3 Security Misconfiguration for Backend User Accounts
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (typo3/cms 9.5.4, 8.7.23), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist typo3/cms
- Affected
- >= 8.0.0, < 8.7.23>= 9.0.0, < 9.5.4
- Fixed in
- 8.7.23, 9.5.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c5mj-39cf-3pp5 lists affected ranges: Packagist typo3/cms >=8.0.0 =9.0.0 <9.5.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
When using the TYPO3 backend in order to create new backend user accounts, database records containing insecure or empty credentials might be persisted. When the type of user account is changed - which might be entity type or the admin flag for backend users - the backend form is reloaded in order to reflect changed configuration possibilities. However, this leads to persisting the current state as well, which can result into some of the following: - account contains empty login credentials (username and/or password) - account is incomplete and contains weak credentials (username and/or password) Albeit the functionality provided by the TYPO3 core cannot be used either with empty usernames or empty passwords, it still can be a severe vulnerability to custom authentication service implementations. This weakness cannot be directly exploited and requires interaction on purpose by some backend user having according privileges.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c5mj-39cf-3pp5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-c5mj-39cf-3pp5 Advisory: TYPO3 Security Misconfiguration for Backend User Accounts IDs: GHSA-c5mj-39cf-3pp5 Record: https://patchnext.com/advisories/ghsa-c5mj-39cf-3pp5 (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: typo3/cms 9.5.4, 8.7.23. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist typo3/cms: affected >= 8.0.0, < 8.7.23; >= 9.0.0, < 9.5.4; fixed in 8.7.23, 9.5.4 ## Suggested inspection (read-only) - Packagist typo3/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on typo3/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c5mj-39cf-3pp5 (GitHub-reviewed advisory GHSA-c5mj-39cf-3pp5 lists affected ranges: Packagist typo3/cms >=8.0.0 =9.0.0 <9.5.4) Commands are suggestions: review each one before running it.
Loading voting…