Skip to content

← Actionable
Unratedamended

commonground-api-common unexploitable privilege escalation in JWT authentication middleware

GHSA-c4cm-r9fh-jgj9

What to do

Vendor response not established. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vng-api-common-utrecht

    Affected
    <= 1.3.2
    Fixed in
    no fixed version recorded
  • PyPI vng-api-common

    Affected
    <= 2.0.5
    Fixed in
    no fixed version recorded
  • PyPI commonground-api-common

    Affected
    <= 1.12.1
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact This is a privilege escalation vulnerability. The impact is negligible and entirely theoretical. A non-exploitable weakness was found in how the client-supplied JWTs are verified. Because an explicit allow-list of known algorithms is used in the PyJWT library, user-supplied (invalid) algorithms are rejected. If this was not the case, then the client JWTs could be tampered with, resulting in privilege escalation which would allow the attacker to perform any operation as any client (impersonation) without leaving a trace of the real user/client. Patches Will be fixed in 1.12.2 Workarounds None needed. But be careful when updating PyJWT. Check that the used PyJWT has no algorithms specified with a name in "", "HS25", "HS2", "HS", "H", or that those algorithms are acceptable. Details The header and payload of JSON Web Tokens (JWTs) are cryptographically signed with an algorithm. A JWT has a header field alg that specifies the algorithm used in the signature. The…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-c4cm-r9fh-jgj9

  2. Revision 1 · created ·

    Published from osv record GHSA-c4cm-r9fh-jgj9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-c4cm-r9fh-jgj9

Advisory: commonground-api-common unexploitable privilege escalation in JWT authentication middleware
IDs: GHSA-c4cm-r9fh-jgj9
Record: https://patchnext.com/advisories/ghsa-c4cm-r9fh-jgj9 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor response not established. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vng-api-common-utrecht: affected <= 1.3.2
- PyPI vng-api-common: affected <= 2.0.5
- PyPI commonground-api-common: affected <= 1.12.1

## Suggested inspection (read-only)
- `python -m pip show vng-api-common-utrecht`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show vng-api-common`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show commonground-api-common`: prints the installed version. Run with the environment that serves production active.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vng-api-common-utrecht, vng-api-common, commonground-api-common.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c4cm-r9fh-jgj9 (OSV record GHSA-c4cm-r9fh-jgj9 lists affected ranges: PyPI commonground-api-common >=0 =0 =0 <=1.3.2)
- Verified: https://github.com/advisories/GHSA-c4cm-r9fh-jgj9 (GitHub-reviewed advisory GHSA-c4cm-r9fh-jgj9 lists affected ranges: PyPI commonground-api-common >=0 =0 =0 <=1.3.2)

Commands are suggestions: review each one before running it.

Loading voting…