Cedar: JSON template is in scope missing slot-id validation allows link panic and decision divergence
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@cedar-policy/cedar-wasm 4.11.1, 3.4.3; cedar-policy 4.11.1, 3.4.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 4.0.1, < 4.11.1>= 3.2.0, < 3.4.3
- Fixed in
- 4.11.1, 3.4.3
crates.io cedar-policy
- Affected
- >= 4.0.0, < 4.11.1>= 3.0.0, < 3.4.3
- Fixed in
- 4.11.1, 3.4.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c33x-vcv4-vg3g lists affected ranges: crates.io cedar-policy >=4.0.0 =3.0.0 =4.0.1 =3.2.0 <3.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c33x-vcv4-vg3g lists affected ranges: crates.io cedar-policy >=4.0.0 =3.0.0 =4.0.1 =3.2.0 <3.4.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:L/SC:L/SI:L/SA:L · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Cedar users must be using all of the following features to be affected by this advisory: JSON format policies, policy templates, and the `is in` scope condition. This advisory only affects JSON-formatted Cedar policy templates containing `is in` scope conditions that are malformed according to the Cedar syntax. It does not affect syntactically well-formed policies. Users of Cedar who author policies in the JSON format were able to write Cedar policies using the `is in` condition with an incorrect slot identifier in the principal and resource scope constraints (e.g., `?principal` in the resource scope constraint) even though this is not allowed when parsing policies from the Cedar policy syntax. Internally, the slot identifiers were silently corrected (e.g. `?resource` is placed in the resource scope constraint). If the policy contains *exactly one slot* in either the principal or resource position, then any attempt to create a linked policy from the template results in an…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-c33x-vcv4-vg3g
- Revision 1 · created ·
Published from ghsa record GHSA-c33x-vcv4-vg3g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-c33x-vcv4-vg3g Advisory: Cedar: JSON template is in scope missing slot-id validation allows link panic and decision divergence IDs: GHSA-c33x-vcv4-vg3g Record: https://patchnext.com/advisories/ghsa-c33x-vcv4-vg3g (revision 2, source checked 30 Oct 2026, 06:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @cedar-policy/cedar-wasm 4.11.1, 3.4.3; cedar-policy 4.11.1, 3.4.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @cedar-policy/cedar-wasm: affected >= 4.0.1, < 4.11.1; >= 3.2.0, < 3.4.3; fixed in 4.11.1, 3.4.3 - crates.io cedar-policy: affected >= 4.0.0, < 4.11.1; >= 3.0.0, < 3.4.3; fixed in 4.11.1, 3.4.3 ## Suggested inspection (read-only) - `npm ls @cedar-policy/cedar-wasm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - crates.io cedar-policy: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @cedar-policy/cedar-wasm, cedar-policy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c33x-vcv4-vg3g (GitHub-reviewed advisory GHSA-c33x-vcv4-vg3g lists affected ranges: crates.io cedar-policy >=4.0.0 =3.0.0 =4.0.1 =3.2.0 <3.4.3) - Verified: https://osv.dev/vulnerability/GHSA-c33x-vcv4-vg3g (OSV record GHSA-c33x-vcv4-vg3g lists affected ranges: crates.io cedar-policy >=4.0.0 =3.0.0 =4.0.1 =3.2.0 <3.4.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…