Scrapy before 2.6.2 and 1.8.3 vulnerable to one proxy sending credentials to another
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (scrapy 2.6.2, 1.8.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI scrapy
- Affected
- < 1.8.3>= 2.0.0, < 2.6.2
- Fixed in
- 1.8.3, 2.6.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9x8m-2xpf-crp3 lists affected ranges: PyPI scrapy >=0 =2.0.0 <2.6.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9x8m-2xpf-crp3 lists affected ranges: PyPI scrapy >=0 =2.0.0 <2.6.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact When the built-in HTTP proxy downloader middleware processes a request with proxy metadata, and that proxy metadata includes proxy credentials, the built-in HTTP proxy downloader middleware sets the Proxy-Authentication header, but only if that header is not already set. There are third-party proxy-rotation downloader middlewares that set different proxy metadata every time they process a request. Because of request retries and redirects, the same request can be processed by downloader middlewares more than once, including both the built-in HTTP proxy downloader middleware and any third-party proxy-rotation downloader middleware. These third-party proxy-rotation downloader middlewares could change the proxy metadata of a request to a new value, but fail to remove the Proxy-Authentication header from the previous value of the proxy metadata, causing the credentials of one proxy to be leaked to a different proxy. If you rotate proxies from different proxy providers, and any of…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9x8m-2xpf-crp3
- Revision 1 · created ·
Published from osv record GHSA-9x8m-2xpf-crp3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-9x8m-2xpf-crp3 Advisory: Scrapy before 2.6.2 and 1.8.3 vulnerable to one proxy sending credentials to another IDs: GHSA-9x8m-2xpf-crp3 Record: https://patchnext.com/advisories/ghsa-9x8m-2xpf-crp3 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: scrapy 2.6.2, 1.8.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI scrapy: affected < 1.8.3; >= 2.0.0, < 2.6.2; fixed in 1.8.3, 2.6.2 ## Suggested inspection (read-only) - `python -m pip show scrapy`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on scrapy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9x8m-2xpf-crp3 (OSV record GHSA-9x8m-2xpf-crp3 lists affected ranges: PyPI scrapy >=0 =2.0.0 <2.6.2 (fixed)) - Verified: https://github.com/advisories/GHSA-9x8m-2xpf-crp3 (GitHub-reviewed advisory GHSA-9x8m-2xpf-crp3 lists affected ranges: PyPI scrapy >=0 =2.0.0 <2.6.2) Commands are suggestions: review each one before running it.
Loading voting…