Skip to content

← Actionable
Unratedamended

Signature verification vulnerability in Stark Bank ecdsa libraries

GHSA-9wx7-jrvc-28mm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (starkbank-ecdsa 1.1.3; com.starkbank:ecdsa-java 1.0.1; starkbank-ecdsa 2.0.1; starkbank-ecdsa 1.3.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

An attacker can forge signatures on arbitrary messages that will verify for any public key. This may allow attackers to authenticate as any user within the Stark Bank platform, and bypass signature verification needed to perform operations on the platform, such as send payments and transfer funds. Additionally, the ability for attackers to forge signatures may impact other users and projects using these libraries in different and unforeseen ways.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9wx7-jrvc-28mm

  2. Revision 1 · created ·

    Published from osv record GHSA-9wx7-jrvc-28mm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-9wx7-jrvc-28mm

Advisory: Signature verification vulnerability in Stark Bank ecdsa libraries
IDs: GHSA-9wx7-jrvc-28mm
Record: https://patchnext.com/advisories/ghsa-9wx7-jrvc-28mm (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: starkbank-ecdsa 1.1.3; com.starkbank:ecdsa-java 1.0.1; starkbank-ecdsa 2.0.1; starkbank-ecdsa 1.3.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm starkbank-ecdsa: affected >= 1.1.2, <= 1.1.2; fixed in 1.1.3
- Maven com.starkbank:ecdsa-java: affected >= 1.0.0, <= 1.0.0; fixed in 1.0.1
- PyPI starkbank-ecdsa: affected < 2.0.1; fixed in 2.0.1
- NuGet starkbank-ecdsa: affected >= 1.3.1, <= 1.3.1; fixed in 1.3.2

## Suggested inspection (read-only)
- `npm ls starkbank-ecdsa --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- Maven com.starkbank:ecdsa-java: check the installed version with your package manager.
- `python -m pip show starkbank-ecdsa`: prints the installed version. Run with the environment that serves production active.
- NuGet starkbank-ecdsa: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on starkbank-ecdsa, com.starkbank:ecdsa-java.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9wx7-jrvc-28mm (OSV record GHSA-9wx7-jrvc-28mm lists affected ranges: PyPI starkbank-ecdsa >=0 =1.0.0 =1.3.1 =1.1.2 <1.1.3 (fixed))
- Verified: https://github.com/advisories/GHSA-9wx7-jrvc-28mm (GitHub-reviewed advisory GHSA-9wx7-jrvc-28mm lists affected ranges: PyPI starkbank-ecdsa >=0 =1.0.0 =1.3.1 =1.1.2 <=1.1.2)

Commands are suggestions: review each one before running it.

Loading voting…