doctrine/doctrine-module zero-valued authentication credentials vulnerability
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (doctrine/doctrine-module 0.7.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist doctrine/doctrine-module
- Affected
- < 0.7.2
- Fixed in
- 0.7.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9wv8-3h8h-x2wc lists affected ranges: Packagist doctrine/doctrine-module >=0 <0.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
it is possible (under certain circumstances) to obtain a valid Zend\Authentication identity even without knowing the user's credentials by using a numerically valued credential in DoctrineModule\Authentication\Adapter\ObjectRepository.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9wv8-3h8h-x2wc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-9wv8-3h8h-x2wc Advisory: doctrine/doctrine-module zero-valued authentication credentials vulnerability IDs: GHSA-9wv8-3h8h-x2wc Record: https://patchnext.com/advisories/ghsa-9wv8-3h8h-x2wc (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: doctrine/doctrine-module 0.7.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist doctrine/doctrine-module: affected < 0.7.2; fixed in 0.7.2 ## Suggested inspection (read-only) - Packagist doctrine/doctrine-module: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on doctrine/doctrine-module. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9wv8-3h8h-x2wc (GitHub-reviewed advisory GHSA-9wv8-3h8h-x2wc lists affected ranges: Packagist doctrine/doctrine-module >=0 <0.7.2) Commands are suggestions: review each one before running it.
Loading voting…