github.com/kumahq/kuma affected by CVE-2023-44487
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kumahq/kuma 2.4.3, 2.3.3, 2.2.4, 2.1.8, 2.0.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 2.4.0, < 2.4.3>= 2.3.0, < 2.3.3>= 2.2.0, < 2.2.4>= 2.1.0, < 2.1.8< 2.0.8
- Fixed in
- 2.2.4, 2.1.8, 2.3.3, 2.4.3, 2.0.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9wmc-rg4h-28wv lists affected ranges: Go github.com/kumahq/kuma >=2.4.0 =2.3.0 =2.2.0 =2.1.0 =0 <2.0.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact Envoy and Go HTTP/2 protocol stack is vulnerable to the "Rapid Reset" class of exploits, which send a sequence of HEADERS frames optionally followed by RSTSTREAM frames. This can be exercised if you use the builtin gateway and receive untrusted http2 traffic. Patches https://github.com/kumahq/kuma/pull/8023 https://github.com/kumahq/kuma/pull/8001 https://github.com/kumahq/kuma/pull/8034 Workarounds Disable http2 on the gateway listener with a MeshProxyPatch or ProxyTemplate. References https://github.com/advisories/GHSA-qppj-fm5r-hxr3 https://github.com/golang/go/issues/63417 https://github.com/envoyproxy/envoy/security/advisories/GHSA-jhv4-f7mr-xx76 https://cloud.google.com/blog/products/identity-security/how-it-works-the-novel-http2-rapid-reset-ddos-attack https://www.nginx.com/blog/http-2-rapid-reset-attack-impacting-f5-nginx-products/?sf269548684=1 https://www.envoyproxy.io/docs/envoy/latest/configuration/bestpractices/edge
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9wmc-rg4h-28wv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-9wmc-rg4h-28wv Advisory: github.com/kumahq/kuma affected by CVE-2023-44487 IDs: GHSA-9wmc-rg4h-28wv Record: https://patchnext.com/advisories/ghsa-9wmc-rg4h-28wv (revision 1, source checked 26 Oct 2026, 14:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/kumahq/kuma 2.4.3, 2.3.3, 2.2.4, 2.1.8, 2.0.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/kumahq/kuma: affected >= 2.4.0, < 2.4.3; >= 2.3.0, < 2.3.3; >= 2.2.0, < 2.2.4; >= 2.1.0, < 2.1.8; < 2.0.8; fixed in 2.2.4, 2.1.8, 2.3.3, 2.4.3, 2.0.8 ## Suggested inspection (read-only) - Go github.com/kumahq/kuma: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/kumahq/kuma. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9wmc-rg4h-28wv (GitHub-reviewed advisory GHSA-9wmc-rg4h-28wv lists affected ranges: Go github.com/kumahq/kuma >=2.4.0 =2.3.0 =2.2.0 =2.1.0 =0 <2.0.8) Commands are suggestions: review each one before running it.
Loading voting…