Expired tokens can be renewed without validating the account password
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (emailproxy 2023.12.19), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI emailproxy
- Affected
- <= 2023.11.18
- Fixed in
- 2023.12.19
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9wgg-m99q-hhfc lists affected ranges: PyPI emailproxy >=0 <2023.12.19 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9wgg-m99q-hhfc lists affected ranges: PyPI emailproxy >=0 <=2023.11.18
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact In versions of the proxy from 2022-09-05 onwards (since 8c874c2ff3d503ac20c7d32f46e08547fcb9e23f), expired OAuth 2.0 client credentials grant (CCG) flow authorisation tokens could be renewed automatically without checking their validity against the original account configuration (i.e., the password that was set up when first creating an account in the proxy). An attacker with knowledge of valid account addresses and careful timing (specifically, attempting to log in during a period from 10 minutes prior to the token expiry time, but before a genuine login request is received) could use this issue to gain access to an account. This issue is only a security concern if you use the proxy with the CCG flow and no additional account secret encryption (see below). If this is the case, it is particularly important to update if you use the proxy in a publicly-accessible setting (i.e., it is available from the internet or across a network). To fix the issue you should switch to version…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9wgg-m99q-hhfc
- Revision 1 · created ·
Published from osv record GHSA-9wgg-m99q-hhfc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-9wgg-m99q-hhfc Advisory: Expired tokens can be renewed without validating the account password IDs: GHSA-9wgg-m99q-hhfc Record: https://patchnext.com/advisories/ghsa-9wgg-m99q-hhfc (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: emailproxy 2023.12.19. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI emailproxy: affected <= 2023.11.18; fixed in 2023.12.19 ## Suggested inspection (read-only) - `python -m pip show emailproxy`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on emailproxy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9wgg-m99q-hhfc (OSV record GHSA-9wgg-m99q-hhfc lists affected ranges: PyPI emailproxy >=0 <2023.12.19 (fixed)) - Verified: https://github.com/advisories/GHSA-9wgg-m99q-hhfc (GitHub-reviewed advisory GHSA-9wgg-m99q-hhfc lists affected ranges: PyPI emailproxy >=0 <=2023.11.18) Commands are suggestions: review each one before running it.
Loading voting…