Skip to content

← Actionable
High, CVSS 7.5

Zendframework potential security issue in login mechanism

GHSA-9v78-h226-2rmq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (zendframework/zendframework1 1.12.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Using the Consumer component of ZendOpenId (or ZendOpenId in ZF1), it is possible to login using an arbitrary OpenID account (without knowing any secret information) by using a malicious OpenID Provider. That means OpenID it is possible to login using arbitrary OpenID Identity (MyOpenID, Google, etc), which are not under the control of our own OpenID Provider. Thus, we are able to impersonate any OpenID Identity against the framework. Moreover, the Consumer accepts OpenID tokens with arbitrary signed elements. The framework does not check if, for example, both openid.claimedid and openid.endpointurl are signed. It is just sufficient to sign one parameter. According to https://openid.net/specs/openid-authentication-20.html#positiveassertions, at least opendpoint, returnto, responsenonce, assochandle, and, if present in the response, claimedid and identity, must be signed.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9v78-h226-2rmq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-9v78-h226-2rmq

Advisory: Zendframework potential security issue in login mechanism
IDs: GHSA-9v78-h226-2rmq
Record: https://patchnext.com/advisories/ghsa-9v78-h226-2rmq (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: zendframework/zendframework1 1.12.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist zendframework/zendframework1: affected >= 1.12.0, < 1.12.4; fixed in 1.12.4

## Suggested inspection (read-only)
- Packagist zendframework/zendframework1: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on zendframework/zendframework1.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9v78-h226-2rmq (GitHub-reviewed advisory GHSA-9v78-h226-2rmq lists affected ranges: Packagist zendframework/zendframework1 >=1.12.0 <1.12.4)

Commands are suggestions: review each one before running it.

Loading voting…