Skip to content

← Actionable
Medium, CVSS 5.3amended

Vercel Workflow Allows Webhook Creation with Predictable User-Specified Tokens

GHSA-9r75-g2cr-3h76

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (workflow 4.2.0-beta.64; @workflow/core 4.2.0-beta.64), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm workflow

    Affected
    <= 4.1.0-beta.63
    Fixed in
    4.2.0-beta.64
  • npm @workflow/core

    Affected
    <= 4.1.0-beta.63
    Fixed in
    4.2.0-beta.64

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

createWebhook() in Vercel Workflow DevKit accepts a user-specified token parameter that serves as the credential for the public webhook endpoint /.well-known/workflow/v1/webhook/{token}. Official documentation recommended predictable token patterns, making it possible for an unauthenticated remote attacker to guess the token and inject arbitrary payloads into the workflow execution context. Impact An attacker who guesses a webhook token can resume the associated workflow with an attacker-controlled HTTP request body, potentially triggering downstream side effects such as API calls, database writes, or deployments. Fix Upgrade to version 4.2.0-beta.64. The fix removes the token option from createWebhook() so that webhook tokens are always randomly generated by the SDK. Runs created with versions prior to 4.2.0-beta.64, that are 1) still active (i.e. running), and 2) have open hooks, are still susceptible to this vulnerability. If users suspect the hook tokens are predictable or leaked…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9r75-g2cr-3h76

  2. Revision 1 · created ·

    Published from osv record GHSA-9r75-g2cr-3h76

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-9r75-g2cr-3h76

Advisory: Vercel Workflow Allows Webhook Creation with Predictable User-Specified Tokens
IDs: GHSA-9r75-g2cr-3h76
Record: https://patchnext.com/advisories/ghsa-9r75-g2cr-3h76 (revision 2, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: workflow 4.2.0-beta.64; @workflow/core 4.2.0-beta.64. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm workflow: affected <= 4.1.0-beta.63; fixed in 4.2.0-beta.64
- npm @workflow/core: affected <= 4.1.0-beta.63; fixed in 4.2.0-beta.64

## Suggested inspection (read-only)
- `npm ls workflow --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @workflow/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on workflow, @workflow/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9r75-g2cr-3h76 (OSV record GHSA-9r75-g2cr-3h76 lists affected ranges: npm workflow >=0 =0 <4.2.0-beta.64 (fixed))
- Verified: https://github.com/advisories/GHSA-9r75-g2cr-3h76 (GitHub-reviewed advisory GHSA-9r75-g2cr-3h76 lists affected ranges: npm workflow >=0 =0 <=4.1.0-beta.63)

Commands are suggestions: review each one before running it.

Loading voting…