Skip to content

← Actionable
Critical, CVSS 10.0amended

Next.js is vulnerable to RCE in React flight protocol

GHSA-9qr9-h5gf-34mp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 16.0.7, 15.5.7, 15.4.8, 15.3.6, 15.2.6, 15.1.9, 15.0.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next

    Affected
    >= 14.3.0-canary.77, < 15.0.5>= 15.2.0-canary.0, < 15.2.6>= 15.3.0-canary.0, < 15.3.6>= 15.4.0-canary.0, < 15.4.8>= 16.0.0-canary.0, < 16.0.7>= 15.1.0-canary.0, < 15.1.9>= 15.5.0-canary.0, < 15.5.7
    Fixed in
    15.4.8, 15.1.9, 15.3.6, 16.0.7, 15.2.6, 15.5.7, 15.0.5

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-9qr9-h5gf-34mp lists affected ranges: npm next >=14.3.0-canary.77 =15.2.0-canary.0 =15.3.0-canary.0 =15.4.0-canary.0 =16.0.0-canary.0 =15.1.0-canary.0 =15.5.0-canary.0 <15.5.7

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

  • Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database

    OSV record GHSA-9qr9-h5gf-34mp lists affected ranges: npm next >=14.3.0-canary.77 =15.1.0-canary.0 =15.2.0-canary.0 =15.3.0-canary.0 =15.4.0-canary.0 =15.5.0-canary.0 =16.0.0-canary.0 <16.0.7 (fixed)

    VerifiedObserved Structured OSV record; GitHub-reviewed advisory.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

A vulnerability affects certain React packages<sup1</sup for versions 19.0.0, 19.1.0, 19.1.1, and 19.2.0 and frameworks that use the affected packages, including Next.js 15.x and 16.x using the App Router. The issue is tracked upstream as CVE-2025-55182. Fixed in: React: 19.0.1, 19.1.2, 19.2.1 Next.js: 15.0.5, 15.1.9, 15.2.6, 15.3.6, 15.4.8, 15.5.7, 16.0.7, 15.6.0-canary.58, 16.1.0-canary.12+ The vulnerability also affects experimental canary releases starting with 14.3.0-canary.77. Users on any of the 14.3 canary builds should either downgrade to a 14.x stable release or 14.3.0-canary.76. All users of stable 15.x or 16.x Next.js versions should upgrade to a patched, stable version immediately. <sup1</sup The affected React packages are: - react-server-dom-parcel - react-server-dom-turbopack - react-server-dom-webpack

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9qr9-h5gf-34mp

  2. Revision 2 · amended ·

    Amended from osv record GHSA-9qr9-h5gf-34mp

  3. Revision 1 · created ·

    Published from ghsa record GHSA-9qr9-h5gf-34mp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-9qr9-h5gf-34mp

Advisory: Next.js is vulnerable to RCE in React flight protocol
IDs: GHSA-9qr9-h5gf-34mp
Record: https://patchnext.com/advisories/ghsa-9qr9-h5gf-34mp (revision 3, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next 16.0.7, 15.5.7, 15.4.8, 15.3.6, 15.2.6, 15.1.9, 15.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next: affected >= 14.3.0-canary.77, < 15.0.5; >= 15.2.0-canary.0, < 15.2.6; >= 15.3.0-canary.0, < 15.3.6; >= 15.4.0-canary.0, < 15.4.8; >= 16.0.0-canary.0, < 16.0.7; >= 15.1.0-canary.0, < 15.1.9; >= 15.5.0-canary.0, < 15.5.7; fixed in 15.4.8, 15.1.9, 15.3.6, 16.0.7, 15.2.6, 15.5.7, 15.0.5

## Suggested inspection (read-only)
- `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9qr9-h5gf-34mp (GitHub-reviewed advisory GHSA-9qr9-h5gf-34mp lists affected ranges: npm next >=14.3.0-canary.77 =15.2.0-canary.0 =15.3.0-canary.0 =15.4.0-canary.0 =16.0.0-canary.0 =15.1.0-canary.0 =15.5.0-canary.0 <15.5.7)
- Verified: https://osv.dev/vulnerability/GHSA-9qr9-h5gf-34mp (OSV record GHSA-9qr9-h5gf-34mp lists affected ranges: npm next >=14.3.0-canary.77 =15.1.0-canary.0 =15.2.0-canary.0 =15.3.0-canary.0 =15.4.0-canary.0 =15.5.0-canary.0 =16.0.0-canary.0 <16.0.7 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…