Skip to content

← Actionable
Medium, CVSS 4.6

webp crate may expose memory contents when encoding an image

GHSA-9q78-27f3-2jmh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (webp 0.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io webp

    Affected
    < 0.3.1
    Fixed in
    0.3.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.6 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Affected versions of this crate did not check that the input slice passed to "webp::Encoder::encode() is large enough for the specified image dimensions. If the input slice is too short, the library will read out of bounds of the buffer and encode other memory contents as an image, resulting in memory exposure or a segmentation fault. The flaw was corrected in pull request #44 by always validating the input buffer size when constructing the encoder.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9q78-27f3-2jmh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-9q78-27f3-2jmh

Advisory: webp crate may expose memory contents when encoding an image
IDs: GHSA-9q78-27f3-2jmh
Record: https://patchnext.com/advisories/ghsa-9q78-27f3-2jmh (revision 1, source checked 26 Oct 2026, 15:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: webp 0.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io webp: affected < 0.3.1; fixed in 0.3.1

## Suggested inspection (read-only)
- crates.io webp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on webp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9q78-27f3-2jmh (GitHub-reviewed advisory GHSA-9q78-27f3-2jmh lists affected ranges: crates.io webp >=0 <0.3.1)

Commands are suggestions: review each one before running it.

Loading voting…