Skip to content

← Actionable
High, CVSS 7.7amended

Trigger.dev: Cross-tenant SQL injection in the TSQL query compiler (POST /api/v1/query) via unsanitized window-function name

CVE-2026-114081GHSA-9q4r-4842-93vw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (trigger.dev 4.5.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2026-114081: 0.40% estimated exploitation activity in the next 30 days; percentile 33.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A cross-tenant SQL injection in the TSQL query compiler lets any authenticated trigger.dev customer read every other tenant's analytics data. The customer-facing query endpoint POST /api/v1/query accepts a TSQL/TRQL query that is compiled to ClickHouse SQL by internal-packages/tsql. The compiler parameterizes or escapes all user input and injects a per-tenant WHERE guard — except the window-function name, which is concatenated into the SQL string with no allowlist and no escaping. By smuggling a backtick-quoted identifier into that position, an attacker injects a raw subquery (e.g. (SELECT ... FROM taskrunsv2 WHERE organizationid = 'orgVICTIM')) that sits outside the tenant guard, exfiltrating another organization's rows. Verified end-to-end against the real compiler and a live ClickHouse. Details Vulnerable sink — internal-packages/tsql/src/query/printer.ts:3073-3075, ClickHousePrinter.visitWindowFunction: node.name is emitted directly into the SQL with no allowlist check…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9q4r-4842-93vw

  2. Revision 2 · amended ·

    Amended from osv record GHSA-9q4r-4842-93vw

  3. Revision 1 · created ·

    Published from ghsa record GHSA-9q4r-4842-93vw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-114081

Advisory: Trigger.dev: Cross-tenant SQL injection in the TSQL query compiler (POST /api/v1/query) via unsanitized window-function name
IDs: CVE-2026-114081, GHSA-9q4r-4842-93vw
Record: https://patchnext.com/advisories/ghsa-9q4r-4842-93vw (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: trigger.dev 4.5.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm trigger.dev: affected <= 4.5.5; fixed in 4.5.6

## Suggested inspection (read-only)
- `npm ls trigger.dev --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on trigger.dev.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9q4r-4842-93vw (GitHub-reviewed advisory GHSA-9q4r-4842-93vw lists affected ranges: npm trigger.dev >=0 <=4.5.5)
- Verified: https://osv.dev/vulnerability/GHSA-9q4r-4842-93vw (OSV record GHSA-9q4r-4842-93vw lists affected ranges: npm trigger.dev >=0 <4.5.6 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…