scheb/two-factor-bundle bypass two-factor authentication with remember-me option
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (scheb/two-factor-bundle 4.11.0, 3.26.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist scheb/two-factor-bundle
- Affected
- >= 4.0.0, < 4.11.0< 3.26.0
- Fixed in
- 4.11.0, 3.26.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9phw-7h96-q3rv lists affected ranges: Packagist scheb/two-factor-bundle >=4.0.0 =0 <3.26.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
In versions prior to 3.26.0 and prior to 4.11.0 of the "scheb/two-factor-bundle" project, a security vulnerability allowed attackers to bypass two-factor authentication (2FA) using the rememberme cookie. When the rememberme checkbox was used during login, a "REMEMBERME" cookie was created. Upon redirection to the 2FA page, attackers could manipulate the SESSIONID key, granting access to the homepage "/" and gaining authentication without completing 2FA.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9phw-7h96-q3rv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-9phw-7h96-q3rv Advisory: scheb/two-factor-bundle bypass two-factor authentication with remember-me option IDs: GHSA-9phw-7h96-q3rv Record: https://patchnext.com/advisories/ghsa-9phw-7h96-q3rv (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: scheb/two-factor-bundle 4.11.0, 3.26.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist scheb/two-factor-bundle: affected >= 4.0.0, < 4.11.0; < 3.26.0; fixed in 4.11.0, 3.26.0 ## Suggested inspection (read-only) - Packagist scheb/two-factor-bundle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on scheb/two-factor-bundle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9phw-7h96-q3rv (GitHub-reviewed advisory GHSA-9phw-7h96-q3rv lists affected ranges: Packagist scheb/two-factor-bundle >=4.0.0 =0 <3.26.0) Commands are suggestions: review each one before running it.
Loading voting…