CredSweeper: Recursive archive size-limit bypass in deep scanner allows crafted compressed inputs to exhaust resources
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (credsweeper 1.16.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI credsweeper
- Affected
- >= 1.4.9, < 1.16.0
- Fixed in
- 1.16.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9mqm-qcwf-5qhg lists affected ranges: PyPI credsweeper >=1.4.9 <1.16.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9mqm-qcwf-5qhg lists affected ranges: PyPI credsweeper >=1.4.9 <1.16.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary CredSweeper's deep scanner does not enforce recursivelimitsize as a hard limit. Several recursive scanners fully decompress or fully read attacker-controlled content before the remaining budget is validated, and AbstractScanner.recursivescan() continues processing even when the residual budget is already negative. This allows a crafted archive to bypass the intended recursive zip-bomb protection and force excessive memory / CPU consumption when deep scanning is enabled (--depth 0). I confirmed this on upstream commit 8b081acf04311eafe8fbd66ea41d02b0a7a4c6f6 / package version 1.15.8. The issue has two closely related exploitation paths that share the same root cause: 1. Single-stream decompressor bypass: gzip, bzip2, and lzma/xz inputs are fully decompressed first, then the remaining budget is computed, and the recursive scan proceeds even if the result is negative. 2. Multi-entry archive cumulative-budget bypass: zip and tar entries are checked only against the original…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9mqm-qcwf-5qhg
- Revision 1 · created ·
Published from osv record GHSA-9mqm-qcwf-5qhg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-9mqm-qcwf-5qhg Advisory: CredSweeper: Recursive archive size-limit bypass in deep scanner allows crafted compressed inputs to exhaust resources IDs: GHSA-9mqm-qcwf-5qhg Record: https://patchnext.com/advisories/ghsa-9mqm-qcwf-5qhg (revision 2, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: credsweeper 1.16.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI credsweeper: affected >= 1.4.9, < 1.16.0; fixed in 1.16.0 ## Suggested inspection (read-only) - `python -m pip show credsweeper`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on credsweeper. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9mqm-qcwf-5qhg (OSV record GHSA-9mqm-qcwf-5qhg lists affected ranges: PyPI credsweeper >=1.4.9 <1.16.0 (fixed)) - Verified: https://github.com/advisories/GHSA-9mqm-qcwf-5qhg (GitHub-reviewed advisory GHSA-9mqm-qcwf-5qhg lists affected ranges: PyPI credsweeper >=1.4.9 <1.16.0) Commands are suggestions: review each one before running it.
Loading voting…