XSS in richtext custom tag attributes in ezsystems/ezplatform-richtext
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ezsystems/ezplatform-admin-ui 1.5.25.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist ezsystems/ezplatform-admin-ui
- Affected
- >= 1.5.0, <= 1.5.25
- Fixed in
- 1.5.25.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9jp8-cwwx-p64q lists affected ranges: Packagist ezsystems/ezplatform-admin-ui >=1.5.0 <=1.5.25
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
The rich text editor does not escape attribute data when previewing custom tags. This means XSS is possible if custom tags are used, for users who have access to editing rich text content. Frontend content view is not affected, but the vulnerability could be used by editors to attack other editors. The fix ensures custom tag attribute data is escaped in the editor.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9jp8-cwwx-p64q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-9jp8-cwwx-p64q Advisory: XSS in richtext custom tag attributes in ezsystems/ezplatform-richtext IDs: GHSA-9jp8-cwwx-p64q Record: https://patchnext.com/advisories/ghsa-9jp8-cwwx-p64q (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ezsystems/ezplatform-admin-ui 1.5.25.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist ezsystems/ezplatform-admin-ui: affected >= 1.5.0, <= 1.5.25; fixed in 1.5.25.1 ## Suggested inspection (read-only) - Packagist ezsystems/ezplatform-admin-ui: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ezsystems/ezplatform-admin-ui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9jp8-cwwx-p64q (GitHub-reviewed advisory GHSA-9jp8-cwwx-p64q lists affected ranges: Packagist ezsystems/ezplatform-admin-ui >=1.5.0 <=1.5.25) Commands are suggestions: review each one before running it.
Loading voting…