Skip to content

← Actionable
Medium, CVSS 5.2amended

nono-py vulnerable to authorization bypass / policy confusion

GHSA-9j7f-3r4p-pwh6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nono-py 0.11.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nono-py

    Affected
    <= 0.10.1
    Fixed in
    0.11.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.2 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

The python API made a restrictive-looking configuration unsafe by default. A caller could configure only reverse- proxy credential routes, put the child in CapabilitySet.proxyonly, and reasonably expect network access to be limited to those routes. Instead, because empty allowedhosts meant allow-all inside nono-proxy, the child could use the local proxy as a transparent CONNECT tunnel to non-route nominated hosts (not including metadata endpoints). That is an authorization bypass / policy confusion issue: - Intended policy: route-only proxy access. - Actual policy: route-only plus arbitrary transparent CONNECT. - Boundary crossed: sandboxed child gains broader outbound network reach than the Python policy appears to grant. - Impact depends on environment, but it can allow exfiltration or access to unintended internet/internal services through the unsandboxed proxy. This should be classified as medium severity by default, potentially high if users rely on route-only configs for strict…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9j7f-3r4p-pwh6

  2. Revision 1 · created ·

    Published from osv record GHSA-9j7f-3r4p-pwh6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-9j7f-3r4p-pwh6

Advisory: nono-py vulnerable to authorization bypass / policy confusion
IDs: GHSA-9j7f-3r4p-pwh6
Record: https://patchnext.com/advisories/ghsa-9j7f-3r4p-pwh6 (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nono-py 0.11.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nono-py: affected <= 0.10.1; fixed in 0.11.0

## Suggested inspection (read-only)
- `python -m pip show nono-py`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nono-py.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9j7f-3r4p-pwh6 (OSV record GHSA-9j7f-3r4p-pwh6 lists affected ranges: PyPI nono-py >=0 <0.11.0 (fixed))
- Verified: https://github.com/advisories/GHSA-9j7f-3r4p-pwh6 (GitHub-reviewed advisory GHSA-9j7f-3r4p-pwh6 lists affected ranges: PyPI nono-py >=0 <=0.10.1)

Commands are suggestions: review each one before running it.

Loading voting…