Magento LTS vulnerable to Stored XSS via TinyMCE WYSIWYG Editor
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openmage/magento-lts 20.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist openmage/magento-lts
- Affected
- < 20.2.0
- Fixed in
- 20.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9j5w-2cqc-cwj9 lists affected ranges: Packagist openmage/magento-lts >=0 <20.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:L
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
From HackerOne report #1948040 by Halit AKAYDIN (hltakydn) Impact What kind of vulnerability is it? Who is impacted? The TinyMCE WYSIWYG editor fails to filter scripts when rendering the HTML in specially crafted HTML tags. Patches Has the problem been patched? What versions should users upgrade to? This vulnerability was fixed in version 20.2.0 by upgrading TinyMCE to a recent version in https://github.com/OpenMage/magento-lts/pull/3220 Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? The WYSIWYG editor features could be disabled in the configuration. Possibly some WAF appliances would filter this attack. References Are there any links users can visit to find out more? The attack is simply an exploit of the "onmouseover" attribute of an img element as described on OWASP XSS Filter Evasion
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9j5w-2cqc-cwj9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-9j5w-2cqc-cwj9 Advisory: Magento LTS vulnerable to Stored XSS via TinyMCE WYSIWYG Editor IDs: GHSA-9j5w-2cqc-cwj9 Record: https://patchnext.com/advisories/ghsa-9j5w-2cqc-cwj9 (revision 1, source checked 26 Oct 2026, 14:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openmage/magento-lts 20.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist openmage/magento-lts: affected < 20.2.0; fixed in 20.2.0 ## Suggested inspection (read-only) - Packagist openmage/magento-lts: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openmage/magento-lts. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9j5w-2cqc-cwj9 (GitHub-reviewed advisory GHSA-9j5w-2cqc-cwj9 lists affected ranges: Packagist openmage/magento-lts >=0 <20.2.0) Commands are suggestions: review each one before running it.
Loading voting…