Skip to content

← Actionable
High, CVSS 7.5

Yapscan's report receiver server vulnerable to path traversal and log injection

GHSA-9h6h-9g78-86f7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/fkie-cad/yapscan 0.19.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact If you make use of the report receiver server (experimental), a client may be able to forge requests such that arbitrary files on the host can be overwritten (subject to permissions of the yapscan server), leading to loss of data. This is particularly problematic if you do not authenticate clients and/or run the server with elevated permissions. Patches Vulnerable versions: - v0.18.0 - v0.19.0 (unreleased) This problem is patched in version v0.19.1 Workarounds Update to the newer version is highly encouraged! Measures to reduce the risk of this include authenticating clients (see --client-ca flag) and containerization of the yapscan server. References The tracking issue is #35. There you can find the commits, fixing the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9h6h-9g78-86f7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-9h6h-9g78-86f7

Advisory: Yapscan's report receiver server vulnerable to path traversal and log injection
IDs: GHSA-9h6h-9g78-86f7
Record: https://patchnext.com/advisories/ghsa-9h6h-9g78-86f7 (revision 1, source checked 26 Oct 2026, 14:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/fkie-cad/yapscan 0.19.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/fkie-cad/yapscan: affected >= 0.18.0, < 0.19.1; fixed in 0.19.1

## Suggested inspection (read-only)
- Go github.com/fkie-cad/yapscan: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/fkie-cad/yapscan.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9h6h-9g78-86f7 (GitHub-reviewed advisory GHSA-9h6h-9g78-86f7 lists affected ranges: Go github.com/fkie-cad/yapscan >=0.18.0 <0.19.1)

Commands are suggestions: review each one before running it.

Loading voting…