Timing side channel vulnerability in endpoint request handler in Vaadin 15-19
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.vaadin:vaadin-bom 19.0.1, 18.0.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.vaadin:vaadin-bom
- Affected
- >= 19.0.0, <= 19.0.0>= 15.0.0, < 18.0.7
- Fixed in
- 18.0.7, 19.0.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9h6g-6mxg-vvp4 lists affected ranges: Maven com.vaadin:vaadin-bom >=19.0.0 =15.0.0 <18.0.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.0 · CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Non-constant-time comparison of CSRF tokens in endpoint request handler in com.vaadin:flow-server versions 3.0.0 through 5.0.3 (Vaadin 15.0.0 through 18.0.6), and com.vaadin:fusion-endpoint version 6.0.0 (Vaadin 19.0.0) allows attacker to guess a security token for Fusion endpoints via timing attack. - https://vaadin.com/security/cve-2021-31406
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9h6g-6mxg-vvp4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-9h6g-6mxg-vvp4 Advisory: Timing side channel vulnerability in endpoint request handler in Vaadin 15-19 IDs: GHSA-9h6g-6mxg-vvp4 Record: https://patchnext.com/advisories/ghsa-9h6g-6mxg-vvp4 (revision 1, source checked 26 Oct 2026, 15:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.vaadin:vaadin-bom 19.0.1, 18.0.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.vaadin:vaadin-bom: affected >= 19.0.0, <= 19.0.0; >= 15.0.0, < 18.0.7; fixed in 18.0.7, 19.0.1 ## Suggested inspection (read-only) - Maven com.vaadin:vaadin-bom: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.vaadin:vaadin-bom. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9h6g-6mxg-vvp4 (GitHub-reviewed advisory GHSA-9h6g-6mxg-vvp4 lists affected ranges: Maven com.vaadin:vaadin-bom >=19.0.0 =15.0.0 <18.0.7) Commands are suggestions: review each one before running it.
Loading voting…