Neos Flow Information disclosure in entity security
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (neos/flow 4.0.6, 3.3.13, 3.2.13, 3.1.10, 3.0.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist neos/flow
- Affected
- >= 3.0.0, < 3.0.12>= 3.1.0, < 3.1.10>= 3.2.0, < 3.2.13>= 3.3.0, < 3.3.13>= 4.0.0, < 4.0.6
- Fixed in
- 3.2.13, 4.0.6, 3.1.10, 3.3.13, 3.0.12
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9cw3-j7wg-jwj8 lists affected ranges: Packagist neos/flow >=3.0.0 =3.1.0 =3.2.0 =3.3.0 =4.0.0 <4.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
If you had used entity security and wanted to secure entities not just based on the user's role, but on some property of the user (like the company he belongs to), entity security did not work properly together with the doctrine query cache. This could lead to other users re-using SQL queries from the cache which were built for other users; and thus users could see entities which were not destined for them. Am I affected? - Do you use Entity Security? if no, you are not affected. - You disabled the Doctrine Cache (FlowPersistenceDoctrine)? If this is the case, you are not affected. - You use Entity Security in custom Flow or Neos applications. Read on. - If you only used Entity Security based on roles (i.e. role A was allowed to see entities, but role B was denied): In this case, you are not affected. - If you did more advanced stuff using Entity Security (like checking that a customer only sees his own orders; or a hotel only sees its own bookings), you very likely needed to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9cw3-j7wg-jwj8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-9cw3-j7wg-jwj8 Advisory: Neos Flow Information disclosure in entity security IDs: GHSA-9cw3-j7wg-jwj8 Record: https://patchnext.com/advisories/ghsa-9cw3-j7wg-jwj8 (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: neos/flow 4.0.6, 3.3.13, 3.2.13, 3.1.10, 3.0.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist neos/flow: affected >= 3.0.0, < 3.0.12; >= 3.1.0, < 3.1.10; >= 3.2.0, < 3.2.13; >= 3.3.0, < 3.3.13; >= 4.0.0, < 4.0.6; fixed in 3.2.13, 4.0.6, 3.1.10, 3.3.13, 3.0.12 ## Suggested inspection (read-only) - Packagist neos/flow: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on neos/flow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9cw3-j7wg-jwj8 (GitHub-reviewed advisory GHSA-9cw3-j7wg-jwj8 lists affected ranges: Packagist neos/flow >=3.0.0 =3.1.0 =3.2.0 =3.3.0 =4.0.0 <4.0.6) Commands are suggestions: review each one before running it.
Loading voting…