Cross-site Scripting in eZFind spellcheck
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ezsystems/ezfind-ls 2017.12.0.1, 5.4.11.1, 5.3.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist ezsystems/ezfind-ls
- Affected
- >= 2017.12.0, < 2017.12.0.1>= 5.4.0, < 5.4.11.1>= 5.3.0, < 5.3.6.1
- Fixed in
- 5.4.11.1, 2017.12.0.1, 5.3.6.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9cq2-pcgr-8h62 lists affected ranges: Packagist ezsystems/ezfind-ls >=2017.12.0 =5.4.0 =5.3.0 <5.3.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
This security advisory fixes a vulnerability in the legacy eZ Find extension, which can be used with the LegacyBridge in eZ Platform. It affects sites using the "Did you mean...?" spell check / search suggestion feature. This feature is vulnerable to Cross-site Scripting (XSS) injection (reflected XSS). The update adds the necessary escaping of injected code. If you're affected, we recommend that you install it as soon as possible. If you have custom search templates, please make sure you update these as well. Ensure that "searchextras.spellcheckcollation" is followed by the "wash" operator, like this: {$searchextras.spellcheckcollation|wash} To install, use Composer to update to one of the "Resolving versions" mentioned above, or apply this patch manually: https://github.com/ezsystems/ezfind/commit/51c17ea9b1231c20db8221f34d01c649060f1e91
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9cq2-pcgr-8h62
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-9cq2-pcgr-8h62 Advisory: Cross-site Scripting in eZFind spellcheck IDs: GHSA-9cq2-pcgr-8h62 Record: https://patchnext.com/advisories/ghsa-9cq2-pcgr-8h62 (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ezsystems/ezfind-ls 2017.12.0.1, 5.4.11.1, 5.3.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist ezsystems/ezfind-ls: affected >= 2017.12.0, < 2017.12.0.1; >= 5.4.0, < 5.4.11.1; >= 5.3.0, < 5.3.6.1; fixed in 5.4.11.1, 2017.12.0.1, 5.3.6.1 ## Suggested inspection (read-only) - Packagist ezsystems/ezfind-ls: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ezsystems/ezfind-ls. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9cq2-pcgr-8h62 (GitHub-reviewed advisory GHSA-9cq2-pcgr-8h62 lists affected ranges: Packagist ezsystems/ezfind-ls >=2017.12.0 =5.4.0 =5.3.0 <5.3.6.1) Commands are suggestions: review each one before running it.
Loading voting…