@nestjs/platform-fastify: Path-scoped middleware bypass via absolute-form request targets
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@nestjs/platform-fastify 12.0.2, 11.2.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 11.2.4>= 12.0.0, < 12.0.2
- Fixed in
- 11.2.4, 12.0.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9c5c-9qcx-q35q lists affected ranges: npm @nestjs/platform-fastify >=0 =12.0.0 <12.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9c5c-9qcx-q35q lists affected ranges: npm @nestjs/platform-fastify >=0 =12.0.0 <12.0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
| Field | Value | | --- | --- | | Ecosystem | npm | | Package | @nestjs/platform-fastify | | Affected versions | = 12.0.0, < 12.0.2 and < 11.2.4 | | Patched versions | 12.0.2 and 11.2.4 (upgrade to 12.0.3 / 11.2.5) | Summary On the Fastify adapter, an HTTP request that uses an absolute-form request target (GET http://host/path HTTP/1.1 instead of GET /path HTTP/1.1) reaches the route handler without running the path-scoped Nest middleware bound to that route. Applications that enforce authentication or authorization in middleware execute the protected handler with those checks skipped. Impact Any application that - uses @nestjs/platform-fastify, and - binds middleware to specific paths via MiddlewareConsumer.forRoutes(...) or .exclude(...), and - is reachable by a client that controls the raw request line. Node's HTTP server accepts absolute-form targets, so no special server configuration is needed. Exposure is reduced when a reverse proxy in front of the application rewrites the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9c5c-9qcx-q35q
- Revision 2 · amended ·
Amended from osv record GHSA-9c5c-9qcx-q35q
- Revision 1 · created ·
Published from ghsa record GHSA-9c5c-9qcx-q35q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-9c5c-9qcx-q35q Advisory: @nestjs/platform-fastify: Path-scoped middleware bypass via absolute-form request targets IDs: GHSA-9c5c-9qcx-q35q Record: https://patchnext.com/advisories/ghsa-9c5c-9qcx-q35q (revision 3, source checked 26 Oct 2026, 13:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @nestjs/platform-fastify 12.0.2, 11.2.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @nestjs/platform-fastify: affected < 11.2.4; >= 12.0.0, < 12.0.2; fixed in 11.2.4, 12.0.2 ## Suggested inspection (read-only) - `npm ls @nestjs/platform-fastify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @nestjs/platform-fastify. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9c5c-9qcx-q35q (GitHub-reviewed advisory GHSA-9c5c-9qcx-q35q lists affected ranges: npm @nestjs/platform-fastify >=0 =12.0.0 <12.0.2) - Verified: https://osv.dev/vulnerability/GHSA-9c5c-9qcx-q35q (OSV record GHSA-9c5c-9qcx-q35q lists affected ranges: npm @nestjs/platform-fastify >=0 =12.0.0 <12.0.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…