semantic-router exposed to compromised litellm wheel (CVE-2026-42208) via unbounded transitive pin
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (semantic-router 0.1.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI semantic-router
- Affected
- >= 0.1.8, < 0.1.15
- Fixed in
- 0.1.15
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-98x5-vq43-vc5p lists affected ranges: PyPI semantic-router >=0.1.8 <0.1.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-98x5-vq43-vc5p lists affected ranges: PyPI semantic-router >=0.1.8 <0.1.15 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact semantic-router versions 0.1.8 through 0.1.14 declare litellm=1.61.3 with no upper bound. During the window in which litellm==1.82.8 was the latest release on PyPI, a fresh install of any affected semantic-router version could resolve to that compromised wheel. The malicious litellm==1.82.8 wheel ships a litellminit.pth file that executes on Python interpreter startup — no import required. It collects and exfiltrates: - Process environment variables - AWS / GCP / Azure credentials - SSH keys, Kubernetes configs, shell history - Database credentials and CI/CD secrets - Cryptocurrency wallets Stage-two payload encrypts the collected data (AES-256 + embedded RSA pubkey) and POSTs it to https://models.litellm.cloud/. See upstream: BerriAI/litellm#24512 and CVE-2026-42208. Patches Fixed in semantic-router 0.1.15, which raises the floor to litellm=1.83.7. Workarounds If developers cannot upgrade immediately: - Pin litellm=1.83.7,!=1.82.8 explicitly in their own project. - Audit…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-98x5-vq43-vc5p
- Revision 2 · amended ·
Amended from osv record GHSA-98x5-vq43-vc5p
- Revision 1 · created ·
Published from ghsa record GHSA-98x5-vq43-vc5p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-98x5-vq43-vc5p Advisory: semantic-router exposed to compromised litellm wheel (CVE-2026-42208) via unbounded transitive pin IDs: GHSA-98x5-vq43-vc5p Record: https://patchnext.com/advisories/ghsa-98x5-vq43-vc5p (revision 3, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: semantic-router 0.1.15. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI semantic-router: affected >= 0.1.8, < 0.1.15; fixed in 0.1.15 ## Suggested inspection (read-only) - `python -m pip show semantic-router`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on semantic-router. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-98x5-vq43-vc5p (GitHub-reviewed advisory GHSA-98x5-vq43-vc5p lists affected ranges: PyPI semantic-router >=0.1.8 <0.1.15) - Verified: https://osv.dev/vulnerability/GHSA-98x5-vq43-vc5p (OSV record GHSA-98x5-vq43-vc5p lists affected ranges: PyPI semantic-router >=0.1.8 <0.1.15 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…