Auth0 Symfony SDK Deserialization of Untrusted Data vulnerability
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (auth0/symfony 5.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist auth0/symfony
- Affected
- >= 5.0.0-BETA0, <= 5.0.0
- Fixed in
- 5.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-98j6-67v3-mw34 lists affected ranges: Packagist auth0/symfony >=5.0.0-BETA0 <=5.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:H · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Overview The Auth0 Symfony SDK contains a critical vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data. Am I Affected? You are affected by this vulnerability if you meet the following preconditions: 1. Applications using the Auth0 Symfony SDK, versions between 5.0.0 BETA-0 to 5.0.0. 2. Auth0 Symfony SDK uses the Auth0-PHP SDK with version 8.0.0-BETA3 to 8.3.0. Fix Upgrade Auth0/symfony to the latest version (v5.4.0). Acknowledgement Okta would like to thank Andreas Forsblom for discovering this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-98j6-67v3-mw34
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-98j6-67v3-mw34 Advisory: Auth0 Symfony SDK Deserialization of Untrusted Data vulnerability IDs: GHSA-98j6-67v3-mw34 Record: https://patchnext.com/advisories/ghsa-98j6-67v3-mw34 (revision 1, source checked 26 Oct 2026, 14:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: auth0/symfony 5.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist auth0/symfony: affected >= 5.0.0-BETA0, <= 5.0.0; fixed in 5.1.0 ## Suggested inspection (read-only) - Packagist auth0/symfony: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on auth0/symfony. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-98j6-67v3-mw34 (GitHub-reviewed advisory GHSA-98j6-67v3-mw34 lists affected ranges: Packagist auth0/symfony >=5.0.0-BETA0 <=5.0.0) Commands are suggestions: review each one before running it.
Loading voting…