Skip to content

← Actionable
High, CVSS 7.5amended

Shakapacker has environment variable leak via EnvironmentPlugin that exposes secrets to client-side bundles

GHSA-96qw-h329-v5rg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (shakapacker 9.5.0; shakapacker 9.5.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary Since 2017, the default webpack plugins have passed the entire process.env to EnvironmentPlugin. This pattern exposed ALL build environment variables to client-side JavaScript bundles whenever application code (or any dependency) referenced process.env.VARIABLENAME. This is not a regression - the vulnerable code has existed since the original Webpacker implementation. No recent code change in Shakapacker triggered this issue. Impact Any environment variable in the build environment that is referenced in client-side code (including third-party dependencies) is embedded directly into the JavaScript bundle. This includes: - DATABASEURL - Database credentials - AWSSECRETACCESSKEY - AWS credentials - RAILSMASTERKEY - Rails encrypted credentials key - STRIPESECRETKEY, TWILIOAUTHTOKEN - Third-party API keys - Any other secrets present in the build environment Severity: Critical - secrets are exposed in publicly accessible JavaScript files. Root Cause The original code used: This…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-96qw-h329-v5rg

  2. Revision 1 · created ·

    Published from osv record GHSA-96qw-h329-v5rg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-96qw-h329-v5rg

Advisory: Shakapacker has environment variable leak via EnvironmentPlugin that exposes secrets to client-side bundles
IDs: GHSA-96qw-h329-v5rg
Record: https://patchnext.com/advisories/ghsa-96qw-h329-v5rg (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: shakapacker 9.5.0; shakapacker 9.5.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems shakapacker: affected < 9.5.0; fixed in 9.5.0
- npm shakapacker: affected < 9.5.0; fixed in 9.5.0

## Suggested inspection (read-only)
- RubyGems shakapacker: check the installed version with your package manager.
- `npm ls shakapacker --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on shakapacker.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-96qw-h329-v5rg (OSV record GHSA-96qw-h329-v5rg lists affected ranges: npm shakapacker >=0 =0 <9.5.0 (fixed))
- Verified: https://github.com/advisories/GHSA-96qw-h329-v5rg (GitHub-reviewed advisory GHSA-96qw-h329-v5rg lists affected ranges: npm shakapacker >=0 =0 <9.5.0)

Commands are suggestions: review each one before running it.

Loading voting…