Zend-Session session validation vulnerability
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zendframework/zend-session 2.3.4, 2.2.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist zendframework/zend-session
- Affected
- >= 2.0.0, < 2.2.9>= 2.3.0, < 2.3.4
- Fixed in
- 2.3.4, 2.2.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-96c6-m98x-hxjx lists affected ranges: Packagist zendframework/zend-session >=2.0.0 =2.3.0 <2.3.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Zend\Session session validators do not work as expected if set prior to the start of a session. For instance, the following test case fails (where $this-manager is an instance of Zend\Session\SessionManager): The implication is that subsequent calls to Zend\Session\SessionManager#start() (in later requests, assuming a session was created) will not have any validator metadata attached, which causes any validator metadata to be re-built from scratch, thus marking the session as valid. An attacker is thus able to simply ignore session validators such as RemoteAddr or HttpUserAgent, since the "signature" that these validators check against is not being stored in the session.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-96c6-m98x-hxjx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-96c6-m98x-hxjx Advisory: Zend-Session session validation vulnerability IDs: GHSA-96c6-m98x-hxjx Record: https://patchnext.com/advisories/ghsa-96c6-m98x-hxjx (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zendframework/zend-session 2.3.4, 2.2.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist zendframework/zend-session: affected >= 2.0.0, < 2.2.9; >= 2.3.0, < 2.3.4; fixed in 2.3.4, 2.2.9 ## Suggested inspection (read-only) - Packagist zendframework/zend-session: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zendframework/zend-session. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-96c6-m98x-hxjx (GitHub-reviewed advisory GHSA-96c6-m98x-hxjx lists affected ranges: Packagist zendframework/zend-session >=2.0.0 =2.3.0 <2.3.4) Commands are suggestions: review each one before running it.
Loading voting…