Skip to content

← Actionable
Unrated

Unsound API in secp256k1 allows use-after-free and invalid deallocation from safe code

GHSA-969w-q74q-9j8v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (secp256k1 0.24.2, 0.23.5, 0.22.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io secp256k1

    Affected
    >= 0.14.0, < 0.22.2>= 0.23.0, < 0.23.5>= 0.24.0, < 0.24.2
    Fixed in
    0.24.2, 0.22.2, 0.23.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Because of incorrect bounds on method Secp256k1::preallocatedgennew it was possible to cause use-after-free from safe consumer code. It was also possible to "free" memory not allocated by the appropriate allocator. The method takes a place for storing the context as a mutable reference and returns context containing that reference. Because the code internally uses unsafe and the bounds were incorrect it was possible to create a context that outlived the passed reference (e.g. 'static). Because the context can alternatively carry heap-allocated pointer freed on drop it was possible to "deallocate" a pointer that wasn't returned from appropriate allocator. The code decides whether to free the memory based on type parameter but because of missing bound it was possible to construct the context with invalid parameter. You are unaffected if you either don't call Secp256k1::preallocatedgennew manually checked that your usage of the method is sound upgraded to the patched version of…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-969w-q74q-9j8v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-969w-q74q-9j8v

Advisory: Unsound API in `secp256k1` allows use-after-free and invalid deallocation from safe code
IDs: GHSA-969w-q74q-9j8v
Record: https://patchnext.com/advisories/ghsa-969w-q74q-9j8v (revision 1, source checked 26 Oct 2026, 15:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: secp256k1 0.24.2, 0.23.5, 0.22.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io secp256k1: affected >= 0.14.0, < 0.22.2; >= 0.23.0, < 0.23.5; >= 0.24.0, < 0.24.2; fixed in 0.24.2, 0.22.2, 0.23.5

## Suggested inspection (read-only)
- crates.io secp256k1: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on secp256k1.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-969w-q74q-9j8v (GitHub-reviewed advisory GHSA-969w-q74q-9j8v lists affected ranges: crates.io secp256k1 >=0.14.0 =0.23.0 =0.24.0 <0.24.2)

Commands are suggestions: review each one before running it.

Loading voting…