Skip to content

← Actionable
High, CVSS 8.7

fast-able is vulnerable to DoS attack through insecure method

GHSA-95hm-pr6q-298w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-able 1.13.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io fast-able

    Affected
    < 1.13.7
    Fixed in
    1.13.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

The public accessible struct SyncVec has a public safe method getunchecked. It accept a parameter index and used in the getunchecked without sufficient checks as mentioned here.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-95hm-pr6q-298w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-95hm-pr6q-298w

Advisory: fast-able is vulnerable to DoS attack through insecure method
IDs: GHSA-95hm-pr6q-298w
Record: https://patchnext.com/advisories/ghsa-95hm-pr6q-298w (revision 1, source checked 26 Oct 2026, 15:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fast-able 1.13.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io fast-able: affected < 1.13.7; fixed in 1.13.7

## Suggested inspection (read-only)
- crates.io fast-able: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fast-able.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-95hm-pr6q-298w (GitHub-reviewed advisory GHSA-95hm-pr6q-298w lists affected ranges: crates.io fast-able >=0 <1.13.7)

Commands are suggestions: review each one before running it.

Loading voting…