Skip to content

← Actionable
Medium, CVSS 6.8amended

agent-router: MCP session resume does not verify the embedded anti-hijacking subject; default Helm seed makes session IDs forgeable

GHSA-953h-535j-jg2v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/envoyproxy/ai-gateway 1.2.0-rc1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.8 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary The MCP proxy's client-facing session ID embeds the authenticated caller's subject (JWT sub claim) specifically as an anti-hijacking discriminator — matching the Model Context Protocol specification's documented session-hijacking guidance (https://modelcontextprotocol.io/specification/2025-06-18/basic/securitybestpractices#session-hijacking). However, the session-resume path never checks that discriminator against the current caller's identity, so any client that obtains a session ID (its own or another user's) can resume that session and act with it — including on routes with per-user backend sessions. This is aggravated by the official Helm chart shipping a literal, publicly known default seed ("default-insecure-seed") for the key that encrypts these session IDs. Impact An attacker who obtains (or, under the default seed, forges) another user's Mcp-Session-Id value can resume that user's MCP session against the backend MCP server(s) bound to the route — reading…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-953h-535j-jg2v

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-953h-535j-jg2v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-953h-535j-jg2v

Advisory: agent-router: MCP session resume does not verify the embedded anti-hijacking subject; default Helm seed makes session IDs forgeable
IDs: GHSA-953h-535j-jg2v
Record: https://patchnext.com/advisories/ghsa-953h-535j-jg2v (revision 3, source checked 26 Oct 2026, 15:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/envoyproxy/ai-gateway 1.2.0-rc1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/envoyproxy/ai-gateway: affected >= 0.4.0-rc1, < 1.2.0-rc1; fixed in 1.2.0-rc1

## Suggested inspection (read-only)
- Go github.com/envoyproxy/ai-gateway: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/envoyproxy/ai-gateway.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-953h-535j-jg2v (OSV record GHSA-953h-535j-jg2v lists affected ranges: Go github.com/envoyproxy/ai-gateway >=0.4.0-rc1 <1.2.0-rc1 (fixed))
- Verified: https://github.com/advisories/GHSA-953h-535j-jg2v (GitHub-reviewed advisory GHSA-953h-535j-jg2v lists affected ranges: Go github.com/envoyproxy/ai-gateway >=0.4.0-rc1 <1.2.0-rc1)

Commands are suggestions: review each one before running it.

Loading voting…