Sylius Admin Bundle Cross-Site Request Forgery vulnerability
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sylius/admin-bundle 1.2.2, 1.1.9, 1.0.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist sylius/admin-bundle
- Affected
- >= 1.0.0, < 1.0.17>= 1.1.0, < 1.1.9>= 1.2.0, < 1.2.2
- Fixed in
- 1.1.9, 1.2.2, 1.0.17
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-945h-6vcv-pc8h lists affected ranges: Packagist sylius/admin-bundle >=1.0.0 =1.1.0 =1.2.0 <1.2.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Sylius 1.0.0 to 1.0.16, 1.1.0 to 1.1.8, 1.2.0 to 1.2.1 versions of AdminBundle and ResourceBundle are affected by this security issue. This issue has been fixed in Sylius 1.0.17, 1.1.9 and 1.2.2. Development branch for 1.3 release has also been fixed. Description The following actions in the admin panel did not require a CSRF token: - marking order’s payment as completed - marking order’s payment as refunded - marking product review as accepted - marking product review as rejected Resolution The issue is fixed by adding a required CSRF token to those actions. We also fixed ResourceController‘s applyStateMachineTransitionAction method by adding a CSRF token check. If you use that action in the API context, you can disable it by adding csrfprotection: false to its routing configuration
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-945h-6vcv-pc8h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-945h-6vcv-pc8h Advisory: Sylius Admin Bundle Cross-Site Request Forgery vulnerability IDs: GHSA-945h-6vcv-pc8h Record: https://patchnext.com/advisories/ghsa-945h-6vcv-pc8h (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sylius/admin-bundle 1.2.2, 1.1.9, 1.0.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist sylius/admin-bundle: affected >= 1.0.0, < 1.0.17; >= 1.1.0, < 1.1.9; >= 1.2.0, < 1.2.2; fixed in 1.1.9, 1.2.2, 1.0.17 ## Suggested inspection (read-only) - Packagist sylius/admin-bundle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sylius/admin-bundle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-945h-6vcv-pc8h (GitHub-reviewed advisory GHSA-945h-6vcv-pc8h lists affected ranges: Packagist sylius/admin-bundle >=1.0.0 =1.1.0 =1.2.0 <1.2.2) Commands are suggestions: review each one before running it.
Loading voting…