Trojanized pantheon-agents 0.6.1 and 0.6.2 on PyPI ship a credential stealer (supply-chain account compromise)
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pantheon-agents 0.6.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pantheon-agents
- Affected
- >= 0.6.1, <= 0.6.2
- Fixed in
- 0.6.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-93qj-5q5v-3c2h lists affected ranges: PyPI pantheon-agents >=0.6.1 <=0.6.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-93qj-5q5v-3c2h lists affected ranges: PyPI pantheon-agents >=0.6.1 <0.6.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary The PyPI account that publishes pantheon-agents was compromised in the June 2026 "Hades" PyPI supply-chain attack (Mini Shai-Hulud / Miasma lineage). The attacker used a stolen, long-lived PyPI API token to upload trojanized releases pantheon-agents 0.6.1 and 0.6.2 directly to PyPI. Only the PyPI artifacts are affected. The GitHub source repository, its git tags, and all other distribution channels are clean — no malicious code was committed to the repository. Affected - pantheon-agents 0.6.1 and 0.6.2 on PyPI. Not affected: installs from the GitHub source, version 0.6.0 and earlier, and the Desktop / Online apps. Indicators of compromise The malicious wheels ship a -setup.pth file that executes on Python startup. It downloads the Bun JavaScript runtime and runs an obfuscated credential stealer (index.js) that harvests and exfiltrates credentials reachable from the host — environment variables, ~/.pypirc, ~/.npmrc, cloud credentials (~/.aws, etc.), SSH keys, and API tokens.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-93qj-5q5v-3c2h
- Revision 2 · amended ·
Amended from osv record GHSA-93qj-5q5v-3c2h
- Revision 1 · created ·
Published from ghsa record GHSA-93qj-5q5v-3c2h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-93qj-5q5v-3c2h Advisory: Trojanized pantheon-agents 0.6.1 and 0.6.2 on PyPI ship a credential stealer (supply-chain account compromise) IDs: GHSA-93qj-5q5v-3c2h Record: https://patchnext.com/advisories/ghsa-93qj-5q5v-3c2h (revision 3, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pantheon-agents 0.6.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pantheon-agents: affected >= 0.6.1, <= 0.6.2; fixed in 0.6.4 ## Suggested inspection (read-only) - `python -m pip show pantheon-agents`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pantheon-agents. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-93qj-5q5v-3c2h (GitHub-reviewed advisory GHSA-93qj-5q5v-3c2h lists affected ranges: PyPI pantheon-agents >=0.6.1 <=0.6.2) - Verified: https://osv.dev/vulnerability/GHSA-93qj-5q5v-3c2h (OSV record GHSA-93qj-5q5v-3c2h lists affected ranges: PyPI pantheon-agents >=0.6.1 <0.6.4 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…