Skip to content

← Actionable
Low, CVSS 3.7

Wagtail: Identification of documents by SHA1 hash

GHSA-92hv-j533-69wc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wagtail 8.0rc2, 7.4.3, 7.3.4, 7.0.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI wagtail

    Affected
    < 7.0.9>= 7.1, < 7.3.4>= 7.4, < 7.4.3>= 8.0rc1, <= 8.0rc1
    Fixed in
    7.3.4, 7.0.9, 8.0rc2, 7.4.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact By passing specific HTTP headers to the document serve URL endpoint, an attacker was able to determine whether a document with a given ID matched a specified SHA1 hash, regardless of any permission restrictions on the document or knowing its filename. This could allow an attacker to determine whether a document with a specific known hash is present in the Wagtail document library. This vulnerability does not expose the document's contents or any metadata beyond the already known SHA1 hash, and does not expose information about any documents for which the attacker does not know the SHA1 hash. Patches Patched versions have been released as Wagtail 7.0.9, 7.3.4, 7.4.3 and 8.0rc2. Workarounds Site owners who are unable to upgrade can strip If-Match and If-None-Match from anonymous requests to /documents/ at the reverse proxy, or use a custom document model without a filehash attribute. Acknowledgements Many thanks to Anand Himanshu for reporting this issue. For more information If…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-92hv-j533-69wc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-92hv-j533-69wc

Advisory: Wagtail: Identification of documents by SHA1 hash
IDs: GHSA-92hv-j533-69wc
Record: https://patchnext.com/advisories/ghsa-92hv-j533-69wc (revision 1, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wagtail 8.0rc2, 7.4.3, 7.3.4, 7.0.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI wagtail: affected < 7.0.9; >= 7.1, < 7.3.4; >= 7.4, < 7.4.3; >= 8.0rc1, <= 8.0rc1; fixed in 7.3.4, 7.0.9, 8.0rc2, 7.4.3

## Suggested inspection (read-only)
- `python -m pip show wagtail`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wagtail.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-92hv-j533-69wc (GitHub-reviewed advisory GHSA-92hv-j533-69wc lists affected ranges: PyPI wagtail >=0 =7.1 =7.4 =8.0rc1 <=8.0rc1)

Commands are suggestions: review each one before running it.

Loading voting…