Skip to content

← Actionable
High, CVSS 7.5

ZendFramework1 Potential Insufficient Entropy Vulnerability

GHSA-8xhv-gqm4-3w99

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (zendframework/zendframework1 1.12.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

We discovered several methods used to generate random numbers in ZF1 that potentially used insufficient entropy. These random number generators are used in the following method calls: In each case, the methods were using rand() or mtrand(), neither of which can generate cryptographically secure values. This could potentially lead to information disclosure should an attacker be able to brute force the random number generation. Moreover, we discovered a potential security issue in the usage of the opensslrandompseudobytes() function in ZendCryptMath::randBytes, reported in PHP BUG #70014, and the security implications reported in a discussion on the randomcompat library.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8xhv-gqm4-3w99

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-8xhv-gqm4-3w99

Advisory: ZendFramework1 Potential Insufficient Entropy Vulnerability
IDs: GHSA-8xhv-gqm4-3w99
Record: https://patchnext.com/advisories/ghsa-8xhv-gqm4-3w99 (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: zendframework/zendframework1 1.12.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist zendframework/zendframework1: affected >= 1.12.0, < 1.12.18; fixed in 1.12.18

## Suggested inspection (read-only)
- Packagist zendframework/zendframework1: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on zendframework/zendframework1.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8xhv-gqm4-3w99 (GitHub-reviewed advisory GHSA-8xhv-gqm4-3w99 lists affected ranges: Packagist zendframework/zendframework1 >=1.12.0 <1.12.18)

Commands are suggestions: review each one before running it.

Loading voting…